conf/distro/jlime-donkey.conf : Added parted & Dialog to distro_rdepends
[vuplus_openembedded] / packages / phalanx / phalanx_22.bb
1 DESCRIPTION = "Phalanx is a chess playing engine."
2 SECTION = "opie/libs"
3 PRIORITY = "optional"
4 PR = "r3"
5 LICENSE = "GPL"
6 SRC_URI = "http://dusan.freeshell.org/phalanx/phalanx-${PV}.tar.gz \
7            file://gcc3.patch;patch=1 \
8            file://capabilities \
9            file://description"
10 S = "${WORKDIR}/Phalanx-XXII"
11
12 do_compile() {
13         oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" STRIP=echo LD="${CC}"
14 }
15
16 do_install() {
17         install -d ${D}${palmtopdir}/chess/engines/Phalanx
18         install -D -m 755 phalanx ${D}${palmtopdir}/chess/engines/Phalanx/phalanx
19         install -D -m 755 pbook.phalanx ${D}${palmtopdir}/chess/engines/Phalanx/pbook.phalanx
20         >${D}${palmtopdir}/chess/engines/Phalanx/sbook.phalanx
21         >${D}${palmtopdir}/chess/engines/Phalanx/learn.phalanx
22         install -D -m 755 ${WORKDIR}/capabilities ${D}${palmtopdir}/chess/engines/Phalanx/capabilities
23         install -D -m 755 ${WORKDIR}/description ${D}${palmtopdir}/chess/engines/Phalanx/description
24 }
25
26 FILES_${PN} = "${palmtopdir}/chess"