merge of '49118a4c6035353c0f8cf1aa30297dd36e43241f'
[vuplus_openembedded] / packages / pciutils / pciutils_2.2.4.bb
1 DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
2 to PCI bus configuration space and several utilities based on this library.'
3 DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils'
4 SECTION = "console/utils"
5 HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
6 LICENSE = "GPLv2"
7 DEPENDS = "zlib"
8
9 SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
10            file://configure.patch;patch=1 \
11            file://configure-uclibc.patch;patch=1 \
12            file://pcimodules-pciutils.diff;patch=1"
13
14 PARALLEL_MAKE = ""
15
16 PR="r2"
17
18 do_configure () {
19         (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
20 }
21
22 export PREFIX = "${D}${prefix}"
23 export SBINDIR = "${D}${sbindir}"
24 export SHAREDIR = "${D}${datadir}"
25 export MANDIR = "${D}${mandir}"
26
27 LDFLAGS += "-lz"
28
29 do_install () {
30         oe_runmake install
31 }
32 do_install_append () {
33         install -d ${D}/${prefix}/share
34         install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
35 }
36
37 PACKAGES =+ "pciutils-ids"
38 FILES_pciutils-ids="${prefix}/share/pci.ids"