merge of '45fb4fa94d52a65c3a3fa636c6122139173dfa8d'
[vuplus_openembedded] / packages / pciutils / pciutils_2.1.11.bb
1 SECTION = "console/utils"
2 DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
3 to PCI bus configuration space and several utilities based on this library.'
4 DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils'
5 HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
6 LICENSE = "GPLv2"
7
8 PR="r3"
9
10 PARALLEL_MAKE = ""
11 FILES_pciutils-ids="${prefix}/share/pci.ids"
12 PACKAGES =+ "pciutils-ids"
13 SRC_URI = "${KERNELORG_MIRROR}/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
14            file://configure.patch;patch=1 \
15            file://configure-uclibc.patch;patch=1 \
16            file://pcimodules-pciutils-2.1.11.diff;patch=1"
17
18 do_configure () {
19         (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
20 }
21
22 export PREFIX = "${D}${prefix}"
23 export SBINDIR = "${D}${sbindir}"
24 export SHAREDIR = "${D}${datadir}"
25 export MANDIR = "${D}${mandir}"
26
27 do_install () {
28         oe_runmake install
29 }
30 do_install_append () {
31         install -d ${D}/${prefix}/share
32         install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
33 }
34