Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / parted / parted_1.8.8.bb
1 DESCRIPTION = "parted, the GNU partition resizing program"
2 HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3 LICENSE = "GPLv3"
4 SECTION = "console/tools"
5 DEPENDS = "readline e2fsprogs-libs"
6
7 PR = "r1"
8
9 SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
10            file://syscalls.h \
11            file://syscalls.patch;patch=1 \
12 "
13            
14 EXTRA_OECONF = "--disable-Werror ac_cv_func_calloc_0_nonnull=yes"
15
16 inherit autotools pkgconfig
17
18 do_configure_prepend() {
19         cp ${WORKDIR}/syscalls.h ${S}/libparted/arch/
20 }
21
22 do_stage() {
23         autotools_stage_all
24 }