Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / orinoco / orinoco-modules_0.15rc1.bb
1 require orinoco-modules.inc
2
3 DEPENDS = "orinoco-conf spectrum-fw"
4 RDEPENDS += "orinoco-conf"
5 RDEPENDS_orinoco-modules-cs += "orinoco-modules spectrum-fw"
6 FILE_PR = "r8"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/orinoco/orinoco-${PV}.tar.gz \
9            file://makefile_fix.patch;patch=1 \
10            file://list-move.patch;patch=1 \
11            file://add_event.patch;patch=1 \
12            file://add_utsname.patch;patch=1 \
13            file://spectrum_cs_ids.patch;patch=1"
14
15 do_install() {
16         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
17         install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
18 }
19
20 FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"