Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / orinoco / orinoco-modules_0.13e.bb
1 require orinoco-modules.inc
2
3 RDEPENDS_orinoco-modules-cs += "orinoco-modules"
4 PR = "r5"
5
6 SRC_URI += "\
7            file://crosscompile.patch;patch=1 \
8            file://monitor-${PV}.patch;patch=1 \
9            file://spectrum.conf \
10            file://spectrum_fw.h \
11            file://spectrum_cs.c \
12            file://orinoco_cs.conf"
13 S = "${WORKDIR}/orinoco-${PV}"
14
15 do_compile_prepend() {
16         cp -f ${WORKDIR}/spectrum* ${S}/
17 }
18
19 do_install() {
20         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
21         install -d ${D}${sysconfdir}/pcmcia
22         install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
23         install -m 0644 ${WORKDIR}/spectrum.conf ${D}${sysconfdir}/pcmcia/
24         install -m 0644 hermes.conf ${D}${sysconfdir}/pcmcia/
25         install -d ${D}${sysconfdir}/modutils
26         install -m 0644 ${WORKDIR}/orinoco_cs.conf ${D}${sysconfdir}/modutils/
27 }
28
29 FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX} /${sysconfdir}"