Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / oprofile / oprofile_0.9.4.bb
1 SECTION = "devel"
2 DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
3 of profiling all running code at low overhead."
4 LICENSE = "GPL"
5 DEPENDS = "popt binutils"
6 RDEPENDS = "binutils-symlinks"
7 RRECOMMENDS = "kernel-vmlinux"
8 PR = "r0"
9
10 SRC_URI = "\
11         ${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
12         file://opjitconv-execvp-fix.diff;patch=1 \
13         file://0.9.4-armv7a.diff;patch=1 \
14         file://acinclude.m4 \
15         "
16
17 inherit autotools
18
19 EXTRA_OECONF = " \
20         --with-kernel-support \
21         --without-x \
22         "
23
24 do_configure () {
25         cp ${WORKDIR}/acinclude.m4 ${S}/
26         autotools_do_configure
27 }
28
29 do_stage () {
30         # As of 0.9.4 there is a libopagent library to compile and link against.
31         autotools_stage_all
32 }
33
34 PACKAGES = "${PN}-dev ${PN}-doc ${PN}-dbg ${PN}"
35
36 FILES_${PN}-dev += "\
37         ${libdir}/oprofile/lib*.so \
38         ${libdir}/oprofile/lib*.a \
39         ${libdir}/oprofile/lib*.la \
40 "