iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / oprofile / oprofile_0.9.3.bb
1 DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
2 of profiling all running code at low overhead."
3 SECTION = "devel"
4 LICENSE = "GPL"
5 DEPENDS = "popt binutils"
6 PR = "r1"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
9            file://acinclude.m4 \
10            file://opcontrol-busybox-compat.patch;patch=1 \
11            "
12
13 S = "${WORKDIR}/oprofile-${PV}"
14
15 inherit autotools
16
17 # NOTE: this disables the build of the kernel modules.
18 # Should add the oprofile kernel modules, for those with 2.4
19 # kernels, as a seperate .oe file.
20 EXTRA_OECONF = "--with-kernel-support \
21                 --without-x \
22                 --disable-werror "
23
24 do_configure () {
25         cp ${WORKDIR}/acinclude.m4 ${S}/
26         autotools_do_configure
27 }
28 # Available config options
29 #  --enable-abi                 enable abi portability code (default is disabled)
30 #  --enable-pch                 enable precompiled header (default is disabled)
31 #  --enable-gcov                enable option for gcov coverage testing (default is disabled)
32 #  --disable-werror            disable -Werror flag (default is enabled for non-release)
33 #  --disable-optimization      disable optimization flags (default is enabled)
34 #  --with-kernel-support        Use 2.6 kernel (no kernel source tree required)
35 #  --with-linux=dir             Path to Linux source tree
36 #  --with-module-dir=dir        Path to module installation directory
37 #  --with-extra-includes=DIR    add extra include paths
38 #  --with-extra-libs=DIR        add extra library paths
39 #  --with-x                use the X Window System
40 #  --with-qt-dir           where the root of Qt is installed
41 #  --with-qt-includes      where the Qt includes are.
42 #  --with-qt-libraries     where the Qt library is installed.