linux-dm8000: add fixup-memsize patch to use memory size passed from bootloader
[vuplus_openembedded] / packages / opkg / opkg_svn.bb
1 require opkg.inc
2
3 PACKAGES =+ "libopkg-dev libopkg"
4
5 FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
6 FILES_libopkg = "${libdir}/*.so.*"
7
8 # Define a variable to allow distros to run configure earlier.
9 # (for example, to enable loading of ethernet kernel modules before networking starts)
10 OPKG_INIT_POSITION = "98"
11 OPKG_INIT_POSITION_slugos = "41"
12
13 pkg_postinst_${PN} () {
14 #!/bin/sh
15 if [ "x$D" != "x" ]; then
16         install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
17         # this happens at S98 where our good 'ole packages script used to run
18         echo "#!/bin/sh
19 opkg-cl configure
20 " > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
21         chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
22 fi
23
24 update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
25 }
26
27 pkg_postrm_${PN} () {
28 #!/bin/sh
29 update-alternatives --remove opkg ${bindir}/opkg-cl
30 }
31