merge of '7393275c6ccce67cadeb49d4afb3459e56edf8a9'
[vuplus_openembedded] / packages / opkg / opkg_svn.bb
1 require opkg.inc
2
3 PR = "r2"
4
5 PACKAGES =+ "libopkg-dev libopkg"
6
7 FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
8 FILES_libopkg = "${libdir}/*.so.*"
9
10 # Define a variable to allow distros to run configure earlier.
11 # (for example, to enable loading of ethernet kernel modules before networking starts)
12 OPKG_INIT_POSITION = "98"
13 OPKG_INIT_POSITION_slugos = "41"
14
15 pkg_postinst_opkg () {
16 #!/bin/sh
17 if [ "x$D" != "x" ]; then
18         install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
19         # this happens at S98 where our good 'ole packages script used to run
20         echo "#!/bin/sh
21 opkg-cl configure
22 " > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
23         chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
24 fi
25
26 update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
27 }
28
29 pkg_postrm_opkg () {
30 #!/bin/sh
31 update-alternatives --remove opkg ${bindir}/opkg-cl
32 }
33