Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / opkg / opkg-nogpg-nocurl_svn.bb
1 require opkg_svn.bb
2
3 DEPENDS = ""
4 PROVIDES += "opkg"
5
6 SRC_URI += " \
7             file://opkg_wget.patch;patch=1;maxrev=180 \
8             file://reduce-nogpg-noise.patch;patch=1;maxrev=180 \
9             file://opkg_wget_nogpg_01_use_vfork_gunzip.patch;patch=1 \
10             file://opkg_wget_nogpg_02_use_vfork_system.patch;patch=1 \
11             file://opkg_wget_nogpg_03_fix_tmpdirs.patch;patch=1 \
12            "
13 PR = "r3"
14
15 SRCREV = "${SRCREV_pn-opkg}"
16
17 EXTRA_OECONF += "--disable-gpg --enable-static --disable-shared"
18
19 # NOTE: Use this one after svn rev 180 (should be a different recipe)
20 #EXTRA_OECONF += "--disable-gpg --disable-curl --enable-static --disable-shared"
21
22 # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
23 do_configure_prepend() {
24         sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
25 }
26
27 DEFAULT_PREFERENCE = "-1"