Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / opensp / opensp_1.5.bb
1 DESCRIPTION = "OpenSP is a library and a set of tools \
2 for validating, parsing, and manipulating SGML and \
3 XML documents."
4 HOMEPAGE = "http://openjade.sourceforge.net/"
5 SECTION = "libs"
6 LICENSE = "MIT"
7 FILE_PR = "r2"
8
9 # sh4/gcc3.4.4 with -O2 triggers internal compiler errors
10 FULL_OPTIMIZATION_sh4 = "-O1"
11
12 SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz \
13            file://m4.patch;patch=1 \
14            file://attributevalue.patch;patch=1 \
15            file://rangmap-fix.patch;patch=1 \
16            file://fix-docdir.patch;patch=1"
17
18 S = "${WORKDIR}/OpenSP-${PV}"
19
20 inherit autotools
21
22 do_stage () {
23         oe_libinstall -a -so -C lib libosp ${STAGING_LIBDIR}
24         install -d ${STAGING_INCDIR}/OpenSP
25         install -m 0644 ${S}/include/*.h ${STAGING_INCDIR}/OpenSP/
26         install -m 0644 ${S}/include/*.cxx ${STAGING_INCDIR}/OpenSP/
27         install -m 0644 ${S}/config.h ${STAGING_INCDIR}/OpenSP/config.h
28 }
29
30 FILES_${PN} += "${datadir}/OpenSP"