openmoko-session2: add RDEPENDS openmoko-panel-memory and oe-stylize
[vuplus_openembedded] / packages / openmoko2 / openmoko-session2.bb
1 DESCRIPTION = "Custom Matchbox session files for OpenMoko"
2 SECTION = "x11"
3 LICENSE = "GPL"
4 RDEPENDS = "matchbox-panel-2"
5 RDEPENDS += "openmoko-common2 openmoko-today2 openmoko-dialer2 openmoko-panel-memory"
6 RCONFLICTS_${PN} = "openmoko-session matchbox-common"
7 PR = "r66"
8
9 SRC_URI = "\
10   file://etc \
11   file://matchbox-session \
12 "
13
14 S = "${WORKDIR}"
15
16 inherit update-alternatives
17
18 do_install() {
19         install -d ${D}${bindir}
20         install -m 0655 ${WORKDIR}/matchbox-session ${D}${bindir}
21         install -d ${D}${sysconfdir}
22         cp -R ${S}/etc/* ${D}${sysconfdir}
23         rm -fR ${D}${sysconfdir}/.svn
24         rm -fR ${D}${sysconfdir}/matchbox/.svn
25         chmod -R 755 ${D}${sysconfdir}/
26 }
27
28 PACKAGE_ARCH = "all"
29
30 pkg_postinst_openmoko-session2 () {
31 #!/bin/sh -e
32 if [ "x$D" != "x" ]; then
33     exit 1
34 fi
35 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme openmoko-standard-2
36 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme openmoko-standard
37 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 5"
38 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/wallpaper ${datadir}/pixmaps/wallpaper.png
39 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/digital_clock 1
40 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/poky/peripherals/mouse/drag_threshold 8
41 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/openmoko/neod/power_management 2
42 # gstreamer audio settings
43 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosink pulsesink
44 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosrc pulsesrc
45 }
46
47 ALTERNATIVE_NAME = "x-window-manager"
48 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
49 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
50 ALTERNATIVE_PRIORITY = "11"
51
52 CONFFILES_${PN} = "${sysconfdir}/matchbox/session"