iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / openmoko-projects / illume_svn.bb
1 DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
2 HOMEPAGE = "http://illume.projects.openmoko.org/"
3 LICENSE = "MIT/BSD"
4 DEPENDS = "e-wm eet evas ecore edje embryo efreet edbus edje-native embryo-native"
5 RRECOMMENDS = "wamerican"
6 PV = "0.0+svnr${SRCREV}"
7 PR = "r3"
8
9 SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=${PN};proto=https \
10            file://keyboard.patch;patch=1;pnum=0;minrev=17;maxrev=20"
11
12 S = "${WORKDIR}/${PN}"
13
14 inherit autotools pkgconfig
15
16 EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
17                 --x-libraries=${STAGING_LIBDIR} \
18                 --enable-simple-x11 \
19                 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
20
21 FILES_${PN} = "${libdir}/enlightenment/modules/*/*.edj \
22                ${libdir}/enlightenment/modules/*/*.desktop \
23                ${libdir}/enlightenment/modules/*/*/* \
24                ${datadir}/${PN} "
25 FILES_${PN}-dbg += "${libdir}/enlightenment/modules/*/*/.debug/"