Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / opencvs / opencvs_cvs.bb
1 # FIXME: Update to work with some other MD5 implementation.
2 # It's silly to pull in OpenSSL just for that.
3 DEPENDS = "openssl"
4 DESCRIPTION = "BSD-licensed equivalent of the popular versioning system CVS."
5 LICENSE = "BSD"
6 PRIORITY = "optional"
7 SECTION = "console/network"
8 PV = "0.0+cvs${SRCDATE}"
9 PR = "r1"
10
11 SRC_URI = "cvs://anoncvs@anoncvs.ca.openbsd.org/cvs;method=ext;module=src/usr.bin/cvs \
12            file://linux.patch;patch=1"
13 S = "${WORKDIR}/cvs"
14
15 inherit autotools
16
17 do_clean_tree () {
18         rm -rf ${S}/cvs ${S}/cvsd
19 }
20 addtask clean_tree after do_patch before do_configure