iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / olsrd / olsrd_0.4.8.bb
1 DESCRIPTION = "OLSR mesh routing daemon"
2 HOMEPAGE = "http://www.olsr.org"
3 DESCRIPTION_olsrd-libs = "OLSR mesh routing daemon -  optional libraries"
4 SECTION = "console/network"
5 PRIORITY = "optional"
6 LICENSE = "BSD"
7
8 SRC_URI="http://www.olsr.org/releases/0.4/olsrd-${PV}.tar.bz2 \
9         file://init \
10         file://olsrd.conf"
11
12 PACKAGES =+ "olsrd-libs"
13 FILES_olsrd-libs = "${libdir}"
14
15 S = "${WORKDIR}/olsrd-${PV}"
16
17 inherit update-rc.d
18
19 INITSCRIPT_NAME = "olsrd"
20 INITSCRIPT_PARAMS = "defaults"
21
22 do_compile() {
23         touch .depend
24         touch src/cfgparser/.depend
25         oe_runmake OS=linux all libs
26 }
27
28 do_install () {
29         oe_runmake INSTALL_PREFIX=${D} install install_libs
30         install -d ${D}${sysconfdir}/init.d
31         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/olsrd
32         install -m 644 ${WORKDIR}/olsrd.conf ${D}${sysconfdir}
33 }
34
35 CONFFILES_${PN} = "${sysconfdir}/olsrd.conf"