free-image: add 3.11.0
[vuplus_openembedded] / packages / ogre / freeimage_3.11.0.bb
1 LICENSE = "MIT"
2
3 SRC_URI = "${SOURCEFORGE_MIRROR}/freeimage/FreeImage3110.zip"
4
5 S = "${WORKDIR}/FreeImage/"
6
7 do_configure() {
8     sed -i -e /^CC/d \
9            -e /^CXX\ /d \
10            -e /^AR/d \
11            -e /^INCDIR\ /d \
12            -e /^INSTALLDIR\ /d \
13            -e s:'-o root -g root'::g \
14            -e /ldconfig/d \
15     ${S}/Makefile.gnu
16 }
17
18 do_install() {
19         install -d ${D}${libdir}
20         install -d ${D}${includedir}
21         oe_runmake INSTALLDIR="${D}${libdir}" INCDIR="${D}${includedir}" install
22 }
23
24 do_stage() {
25         install -d ${STAGING_LIBDIR}
26         install -d ${STAGING_INCDIR}
27         oe_runmake  INSTALLDIR="${STAGING_LIBDIR}" INCDIR="${STAGING_INCDIR}" install
28 }
29