Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / obexftp / obexftp_0.22.bb
1 DESCRIPTION = "OBEX Ftp Client based on openobex."
2 SECTION = "console/network"
3 HOMEPAGE = "http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
4 LICENSE = "GPL"
5 DEPENDS = "openobex bluez-libs libusb virtual/libiconv"
6 PR = "r0"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.bz2 \
9           "
10
11 inherit autotools pkgconfig
12
13 EXTRA_OECONF += "--enable-bluetooth \
14                  --disable-swig \
15                  --disable-perl \
16                  --disable-python \
17                  --disable-tcl \
18                  --disable-ruby \
19                  --disable-builddocs \
20                  --disable-rpath \
21                 "
22
23 PARALLEL_MAKE = ""
24
25 LEAD_SONAME = "libobexftp.so"
26
27 do_stage() {
28         autotools_stage_all
29 }
30