Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / nunome / nunome_1.0.2.bb
1 DESCRIPTION = "Japanese input method plugin"
2 HOMEPAGE = "http://www.sikigami.com/nunome-Qtopia-1.0/"
3 SECTION = "opie/inputmethods"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 RDEPENDS = "virtual/japanese-font"
7 FILE_PR = "r3"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/gakusei/nunome-${PV}.tar.bz2 \
10         file://timer.patch;patch=1 \
11         file://nunome.patch;patch=1"
12 S = "${WORKDIR}/nunome"
13
14 inherit opie
15
16 EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/Nnmlib INCLUDEPATH+=${S}/ui LIBS+=-L${S}"
17 OE_QMAKE_CXXFLAGS := "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
18 PARALLEL_MAKE = ""
19
20 do_configure_prepend() {
21         sed -i -e 's,/opt/QtPalmtop/bin/,${bindir}/,g' "${S}/ui/nunome.h"
22         sed -i -e 's,/opt/QtPalmtop/,${palmtopdir}/,g' "${S}/ui/nunome.h"
23         printf "TEMPLATE=subdirs\nSUBDIRS=Nnmlib server ui dicman ui\n" >nunome.pro
24         pushd Nnmlib && qmake -project -t lib && popd
25         pushd server && qmake -project && printf "LIBS+=-lNnmlib\nTARGET=server.bin\n" >> server.pro && popd
26         pushd dicman && qmake -project && printf "LIBS+=-lnunome -lNnmlib\nTARGET=dicman.bin\n" >> dicman.pro && popd
27         pushd ui && qmake -project -t lib && printf "LIBS+=-lNnmlib\nTARGET=nunome\n" >> ui.pro && popd
28         find . -name "moc*"|xargs rm -f
29         find . -name "Makefile"|xargs rm -f
30 }
31
32 do_install() {
33         install -d ${D}${palmtopdir}/lib
34         install -d ${D}${bindir}
35         install -d ${D}${palmtopdir}/i18n/ja
36         install -d ${D}${palmtopdir}/share/nunome
37
38         oe_libinstall -so libNnmlib ${D}${palmtopdir}/lib
39         install -m 644 nunome_uni.dic           ${D}${palmtopdir}/share/nunome
40         install -m 755 server.bin               ${D}${bindir}/nnmsrv
41         install -m 755 dicman.bin               ${D}${bindir}/nnmDicman
42         install -m 644 ui/nunome.qm             ${D}${palmtopdir}/i18n/ja
43         install -m 644 dicman/nnmDicman.qm      ${D}${palmtopdir}/i18n/ja
44 }