Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / nrlolsr / nrlolsr_7.8.1.bb
1 DESCRIPTION = "NRL OLSR - added to OE to support the Maniac Challenge (http://www.maniacchallenge.org/)"
2 SECTION = "applications"
3 LICENSE = "Public Domain"
4
5 S="${WORKDIR}/nrlolsr/"
6
7 SRC_URI = "http://downloads.pf.itd.nrl.navy.mil/olsr/nrlolsrdv7.8.1.tgz \
8            file://nrlolsr-cross.patch;patch=1 \
9           "
10
11 do_compile () {
12         cd ${S}/unix
13
14         sed -i -e 's:-I/usr/X11R6/include:-I${STAGING_INCDIR}:g' Makefile.linux
15         sed -i -e 's:-L/usr/X11R6/lib:-L${STAGING_LIBDIR}:g' Makefile.linux
16         sed -i -e 's:/usr/local/bin:${STAGING_BINDIR}:g' Makefile.linux
17         sed -i -e 's:make -f Makefile:make -e -f Makefile:g' Makefile.common
18
19 #       EXTRA_OEMAKE="-f Makefile.linux"
20         oe_runmake -f Makefile.linux
21
22 }
23
24 do_install () {
25         install -d ${D}/${bindir}
26         install unix/nrlolsrd ${D}/${bindir}
27 }