merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / nonworking / r / r_2.0.0.bb
1 DESCRIPTION = "R is GNU S, a freely available language and environment for statistical computing \
2 and graphics which provides a wide variety of statistical and graphical techniques: \
3 linear and nonlinear modelling, statistical tests, time series analysis, classification, clustering, etc."
4 SECTION = "console/scientific"
5 PRIORITY = "optional"
6 DEPENDS = "ncurses readline less perl-native r-native"
7
8 SRC_URI = "http://www.stats.bris.ac.uk/R/src/base/R-2/R-${PV}.tar.gz \
9         file://configure.patch;patch=1 \
10         file://src_library_Makefile.patch;patch=1 \
11         file://src_library_Recommended_Makefile.patch;patch=1 \
12         file://src_library_base_Makefile.patch;patch=1 \
13         file://src_library_tools_Makefile.patch;patch=1 \
14         file://src_library_utils_Makefile.patch;patch=1 \
15         file://src_library_datasets_Makefile.patch;patch=1 \
16         file://src_library_graphics_Makefile.patch;patch=1 \
17         file://src_library_grid_Makefile.patch;patch=1 \
18         file://src_library_methods_Makefile.patch;patch=1 \
19         file://src_library_splines_Makefile.patch;patch=1 \
20         file://src_library_stats4_Makefile.patch;patch=1 \
21         file://src_library_stats_Makefile.patch;patch=1 \
22         file://src_library_tcltk_Makefile.patch;patch=1 \
23         file://src_library_grDevices_Makefile.patch;patch=1"
24
25 S = "${WORKDIR}/R-${PV}"
26
27 inherit autotools
28
29 EXTRA_OECONF = "--without-x"
30
31 do_configure() {
32         gnu-configize
33         oe_runconf
34 }
35
36 do_compile_prepend () {
37         ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} src/extra/pcre/dftables.c -o src/extra/pcre/dftables -Isrc/include
38         touch src/extra/pcre/dftables.o
39         src/extra/pcre/dftables src/extra/pcre/chartables.h
40 }
41
42 do_compile() {
43         oe_runmake 'R_EXE_NATIVE = ${STAGING_BINDIR_NATIVE}/R'
44 }