merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / nonworking / lzma / lzma_0.01.bb
1 DESCRIPTION = "LZMA is a compression algorithm, based on the famous \
2 Lempel Ziff compression method. The windows only open source tool 7-zip \
3 is another tool which uses this algorithm."
4 SECTION = "libs"
5 PRIORITY = "optional"
6
7 SRC_URI = "http://students.fhs-hagenberg.ac.at/se/se00001/lzma-0.01.tar.bz2"
8 S = "${WORKDIR}/"
9
10 inherit qmake
11
12 do_configure_prepend() {
13         ${STAGING_BINDIR_NATIVE}/qmake -project -o lzma.pro
14 }
15
16 do_install_append () {
17         # Make install doesn't properly install these
18         oe_libinstall -so -C shlib libhistory ${D}/${libdir}
19         oe_libinstall -so -C shlib libreadline ${D}/${libdir}
20 }
21
22 do_stage() {
23         oe_libinstall -so -C shlib libhistory ${STAGING_LIBDIR}
24         oe_libinstall -so -C shlib libreadline ${STAGING_LIBDIR}
25
26         install -d ${STAGING_INCDIR}/readline
27         for f in readline.h chardefs.h keymaps.h history.h tilde.h rlstdc.h \
28           rlconf.h rltypedefs.h
29         do
30                 install -m 0644 $f ${STAGING_INCDIR}/readline/
31         done
32
33 }