Bluez: removed outdated stuff so multithreaded bitbake doesn't break apps depending...
[vuplus_openembedded] / packages / nis / pwdutils_2.6.bb
1 # This package builds tools to manage NIS passwords
2 # The source package is utils/net/NIS/pwdutils
3 # The package requires -lpam
4 #
5 PR = "r1"
6 DESCRIPTION="\
7 NIS PAM password management tools.  \
8 This is a collection of utilities to manage the passwd \
9 information stored in local files, NIS, NIS+ or LDAP \
10 and can replace the shadow suite completely."
11 HOMEPAGE="http://lists.suse.com/archive/pwdutils/"
12
13 require nis.inc
14
15 SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/net/NIS/OLD/${PN}/${P}.tar.bz2"
16
17 # an selinux API is used even if no selinux is detected by
18 # configure.
19 SRC_URI += " file://no-selinux.patch;patch=1"
20 SRC_URI += " file://libdl.patch;patch=1"
21
22 DEPENDS += " libpam openldap openssl"
23
24 # -Werror is set within the pwdutils configure.in!
25 # You might prefer to use -Wno-error rather than the
26 # following long list.
27 #
28 # #if undefined happens in bits/string2.h and probably
29 # elsewhere (since it is a standard safe C programming
30 # practice - safer than #ifdef!)
31 TARGET_CFLAGS += " -Wno-undef"
32 # bits/socket.h has a macro which casts 'up' (increasing
33 # the alignment requirement) but it is in a macro which
34 # does the alignment correctly, so the following warning
35 # needs to be non-error'ed.  I just turn it off...
36 TARGET_CFLAGS += " -Wno-cast-align"
37 # openssl contains large numbers of declarations wherein
38 # f() is used instead of f(void), so:
39 TARGET_CFLAGS += " -Wno-strict-prototypes"
40 # openssl uses error as a local variable, so:
41 TARGET_CFLAGS += " -Wno-shadow"