Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / neuros-public / neuros-mainmenu_git.bb
1 DESCRIPTION = "Neuros window manager"
2 LICENSE = "GPL"
3
4 PV = "0.0+${PR}+gitr${SRCREV}"
5 FILE_PR = "r2"
6
7 DEPENDS = "qt-embedded"
8
9 inherit qtopia4core
10
11 SRCREV = "4dfc8ec91c284be45582bc51de8117610269d04d"
12 SRC_URI = "git://git.neurostechnology.com/git/app-mainmenu;protocol=git"
13 S = "${WORKDIR}/git/"
14
15 do_install() {
16         install -d ${D}/${bindir}
17         install -m 0755  ${S}/build/main-menu ${D}/${bindir}
18
19         install -d ${D}/${sysconfdir}/menu
20         install -m 0644 ${S}/resources/menu/* ${D}/${sysconfdir}/menu
21
22         install -d ${D}/${sysconfdir}/nwm
23         echo "${bindir}/mainmenu" > ${D}/${sysconfdir}/nwm/startup
24 }
25
26