Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / netbase / netbase_4.21.bb
1 DESCRIPTION = "This package provides the necessary \
2 infrastructure for basic TCP/IP based networking."
3 SECTION = "base"
4 LICENSE = "GPL"
5 PR = "r28"
6
7 inherit update-rc.d
8
9 SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
10
11 INITSCRIPT_NAME = "networking"
12 INITSCRIPT_PARAMS = "start 40 S . stop 40 0 6 1 ."
13 # On MNCI etc, start very late so that our own apps come up faster
14 INITSCRIPT_PARAMS_openmn = "start 85 1 2 3 4 5 . stop 85 0 6 1 ."
15 # On SlugOS (NSLU2) delay the stop until after network apps have exited
16 # Do not stop in single user - there's no way to sulogin!
17 INITSCRIPT_PARAMS_slugos = "start 42 S 0 6 ."
18
19 SRC_URI = "${DEBIAN_MIRROR}/main/n/netbase/netbase_${PV}.tar.gz \
20            file://options \
21            file://init \
22            file://hosts \
23            file://interfaces \
24            file://if-pre-up.d \
25            file://if-up.d \
26            file://if-down.d \
27            file://if-post-down.d"
28
29 do_install () {
30         install -d ${D}${sysconfdir}/init.d
31         install -d ${D}${sbindir}
32         install -d ${D}${mandir}/man8
33         install -d ${D}${sysconfdir}/network/if-pre-up.d
34         install -d ${D}${sysconfdir}/network/if-up.d
35         install -d ${D}${sysconfdir}/network/if-down.d
36         install -d ${D}${sysconfdir}/network/if-post-down.d
37
38         for dir in if-pre-up.d if-up.d if-down.d if-post-down.d
39         do
40                 for script in `ls -1 "${WORKDIR}/${dir}"`
41                 do              
42                         install -m 0755 "${WORKDIR}/${dir}/${script}" "${D}${sysconfdir}/network/${dir}"
43                 done
44         done
45                    
46         install -m 0644 ${WORKDIR}/options ${D}${sysconfdir}/network/options
47         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/networking
48         install -m 0644 ${WORKDIR}/hosts ${D}${sysconfdir}/hosts
49         install -m 0644 etc-rpc ${D}${sysconfdir}/rpc
50         install -m 0644 etc-protocols ${D}${sysconfdir}/protocols
51         install -m 0644 etc-services ${D}${sysconfdir}/services
52         install -m 0755 update-inetd ${D}${sbindir}/
53         install -m 0644 update-inetd.8 ${D}${mandir}/man8/
54         install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
55 }
56
57 CONFFILES_${PN} = "${sysconfdir}/network/options ${sysconfdir}/hosts \
58                    ${sysconfdir}/network/interfaces ${sysconfdir}/rpc \
59                    ${sysconfdir}/protocols ${sysconfdir}/services"