Merge branch 'org.openembedded.dev' of git@git.openembedded.net:/openembedded into...
[vuplus_openembedded] / packages / musicpd / mpd_svn.bb
1 DESCRIPTION = "Music Player Daemon (mpd)"
2 HOMEPAGE = "http://www.musicpd.org"
3 SECTION = "console/multimedia"
4 LICENSE = "GPLv2"
5 DEPENDS = "libvorbis libogg libao zlib libmikmod flac audiofile virtual/libiconv faad2 pulseaudio \
6            ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag', d)}"
7 PV = "0.12.1+svn${SRCDATE}"
8 PR = "r1"
9
10 SRC_URI = "svn://svn.musicpd.org/mpd;module=trunk;proto=https \
11            file://mpd/mpd.init"
12 #           file://save-volume-state.patch;patch=1"
13 S = "${WORKDIR}/trunk"
14
15 inherit autotools update-rc.d
16 INITSCRIPT_NAME = "mpd"
17
18 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
19 # be built, instead we use the OE built versions which should be installed
20 # in staging - remove the --with and replace with --enable to use the local
21 # versions.
22
23 EXTRA_OECONF = "\
24                 --enable-ogg \
25                 --with-id3tag-libraries=${STAGING_LIBDIR} \
26                 --with-id3tag-includes=${STAGING_INCDIR} \
27                 --with-mad-libraries=${STAGING_LIBDIR} \
28                 --with-mad-includes=${STAGING_INCDIR} \
29         --with-faad-libraries=${STAGING_LIBDIR} \
30                 --with-faad-includes=${STAGING_INCDIR} \
31         --disable-jack \
32         --enable-pulse \
33         --enable-mod \
34         --disable-oggflac"
35
36 do_compile_prepend() {
37     find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
38 }