rootfs_ipk.bbclass: fix string comparison
[vuplus_openembedded] / packages / musicpd / mpd_svn.bb
1 DESCRIPTION = "Music Player Daemon (mpd)"
2 HOMEPAGE = "http://www.musicpd.org"
3 SECTION = "console/multimedia"
4 LICENSE = "GPLv2"
5 DEPENDS = "libvorbis libogg libid3tag libao zlib libmikmod libmad flac audiofile virtual/libiconv faad2 pulseaudio"
6 PV = "0.12.1+svn${SRCDATE}"
7 PR = "r0"
8
9 SRC_URI = "svn://svn.musicpd.org/mpd;module=trunk;proto=https \
10            file://mpd/mpd.init"
11 #           file://save-volume-state.patch;patch=1"
12 S = "${WORKDIR}/trunk"
13
14 inherit autotools update-rc.d
15 INITSCRIPT_NAME = "mpd"
16
17 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
18 # be built, instead we use the OE built versions which should be installed
19 # in staging - remove the --with and replace with --enable to use the local
20 # versions.
21
22 EXTRA_OECONF = "\
23                 --enable-ogg \
24                 --with-id3tag-libraries=${STAGING_LIBDIR} \
25                 --with-id3tag-includes=${STAGING_INCDIR} \
26                 --with-mad-libraries=${STAGING_LIBDIR} \
27                 --with-mad-includes=${STAGING_INCDIR} \
28         --with-faad-libraries=${STAGING_LIBDIR} \
29                 --with-faad-includes=${STAGING_INCDIR} \
30         --disable-jack \
31         --enable-pulse \
32         --enable-mod \
33         --disable-oggflac"
34
35 do_compile_prepend() {
36     find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
37 }