Merge branch 'org.openembedded.dev' of git@git.openembedded.net:/openembedded into...
[vuplus_openembedded] / packages / musicpd / mpd-alsa_svn.bb
1 DESCRIPTION = "Music Player Daemon (mpd). This version is configured for alsa support"
2 HOMEPAGE = "http://www.musicpd.org"
3 SECTION = "console/multimedia"
4 LICENSE = "GPLv2"
5 DEPENDS = "libvorbis libogg libao-alsa zlib flac audiofile virtual/libiconv faad2 \
6            ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag', d)}"
7 RDEPENDS = "libao-alsa"
8 PV = "0.11.5+svnr${SRCREV}"
9 PR = "r2"
10
11 SRC_URI = "svn://svn.musicpd.org/mpd;module=trunk;proto=https \
12                 file://mpd/mpd.init"
13 #           file://mpd/save-volume-state.patch;patch=1 \
14
15 S = "${WORKDIR}/trunk"
16
17 inherit autotools update-rc.d
18 INITSCRIPT_NAME = "mpd"
19
20 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
21 # be built, instead we use the OE built versions which should be installed
22 # in staging - remove the --with and replace with --enable to use the local
23 # versions.
24
25 EXTRA_OECONF = "\
26 --enable-ogg \
27 --enable-oggvorbis \
28 --disable-oggflac \  
29 --enable-flac \ 
30 --enable-faad \
31 --with-ao-libraries=${STAGING_LIBDIR} \
32 --with-ao-includes=${STAGING_INCDIR} \
33 --with-iconv-libraries=${STAGING_LIBDIR} \
34 --with-iconv-includes=${STAGING_INCDIR} \
35 --with-id3tag-libraries=${STAGING_LIBDIR} \
36 --with-id3tag-includes=${STAGING_INCDIR} \
37 --with-faad-libraries=${STAGING_LIBDIR} \
38 --with-faad-includes=${STAGING_INCDIR} \
39 --with-mad-libraries=${STAGING_LIBDIR} \
40 --with-mad-includes=${STAGING_INCDIR} \
41 --with-ogg-libraries=${STAGING_LIBDIR} \
42 --with-ogg-includes=${STAGING_INCDIR} \
43 --with-vorbis-libraries=${STAGING_LIBDIR} \
44 --with-vorbis-includes=${STAGING_INCDIR} \
45 --disable-aotest \      
46 --disable-alsatest \   
47 --disable-oggtest \    
48 --disable-vorbistest \      
49 --disable-libFLACtest \      
50 --disable-libOggFLACtest  \    
51 --disable-audiofiletest  \     
52 --disable-libmikmodtest \
53 "
54
55 do_install_append() {
56         install -d ${D}${sysconfdir}/init.d
57         install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
58 }