rootfs_ipk.bbclass: fix string comparison
[vuplus_openembedded] / packages / musicpd / mpd-alsa_0.11.5.bb
1 DESCRIPTION = "Music Player Daemon (mpd). This version is configured for alsa support"
2 HOMEPAGE = "http://www.musicpd.org"
3 SECTION = "console/multimedia"
4 LICENSE = "GPLv2"
5 DEPENDS = "libvorbis libogg libid3tag libao-alsa zlib libmikmod libmad flac audiofile virtual/libiconv"
6 RDEPENDS = "libao-alsa"
7 PR = "r3"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.gz \
10            file://mpd/save-volume-state.patch;patch=1 file://mpd/mpd.init"
11 S = "${WORKDIR}/mpd-${PV}"
12
13 inherit autotools update-rc.d
14 INITSCRIPT_NAME = "mpd"
15
16 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
17 # be built, instead we use the OE built versions which should be installed
18 # in staging - remove the --with and replace with --enable to use the local
19 # versions.
20
21 EXTRA_OECONF = "--enable-ogg \
22                 --with-iconv-libraries=${STAGING_LIBDIR} \
23                 --with-iconv-includes=${STAGING_INCDIR} \
24                 --with-vorbis-libraries=${STAGING_LIBDIR} \
25                 --with-vorbis-includes=${STAGING_INCDIR} \
26                 --with-ogg-libraries=${STAGING_LIBDIR} \
27                 --with-ogg-includes=${STAGING_INCDIR} \
28                 --with-ao-libraries=${STAGING_LIBDIR} \
29                 --with-ao-includes=${STAGING_INCDIR} \
30                 --with-id3tag-libraries=${STAGING_LIBDIR} \
31                 --with-id3tag-includes=${STAGING_INCDIR} \
32                 --with-mad-libraries=${STAGING_LIBDIR} \
33                 --with-mad-includes=${STAGING_INCDIR} \
34                 --without-faad"
35
36 do_install_append() {
37         install -d ${D}${sysconfdir}/init.d
38         install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
39 }