merge of '82245638ef37f8730477752665cc0965a7c2556c'
[vuplus_openembedded] / packages / multitap-pad / multitap-pad_svn.bb
1 DESCRIPTION = "Multi-tap input method for GTK"
2 LICENSE = "GPL"
3 DEPENDS = "libfakekey gtk+ matchbox-panel-2"
4 RCONFLICTS = matchbox-keyboard-inputmethod
5 SECTION = "x11"
6 PV = "0.0+svnr${SRCREV}"
7
8 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=${PN};proto=http \
9         file://80multitappad"
10
11 inherit autotools pkgconfig
12
13 S = "${WORKDIR}/${PN}"
14
15 FILES_${PN} = "${bindir}/* \
16                ${libdir} \
17                ${sysconfdir} \
18                ${datadir}"
19
20 FILES_${PN}-dbg += " ${libdir}/gtk-2.0/2.10.0/immodules/.debug \
21                      ${libdir}/matchbox-panel/.debug"
22
23 FILES_${PN}-dev += " ${libdir}/gtk-2.0/2.10.0/immodules/*.a \
24                      ${libdir}/gtk-2.0/2.10.0/immodules/*.la \
25                      ${libdir}/matchbox-panel/*.a \
26                      ${libdir}/matchbox-panel/*.la"
27
28 do_install_append () {
29         install -d ${D}/${sysconfdir}/X11/Xsession.d/
30         install -m 755 ${WORKDIR}/80multitappad ${D}/${sysconfdir}/X11/Xsession.d/
31 }
32
33 pkg_postinst_multitap-pad () {
34 if [ "x$D" != "x" ]; then
35   exit 1
36 fi
37
38 gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
39 }
40
41 pkg_postrm_multitap-pad () {
42 if [ "x$D" != "x" ]; then
43   exit 1
44 fi
45
46 gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
47 }