openmoko-session2: add RDEPENDS openmoko-panel-memory and oe-stylize
[vuplus_openembedded] / packages / mplayer / mplayer_0.0+1.0rc1.bb
1 DESCRIPTION = "Open Source multimedia player."
2 SECTION = "multimedia"
3 PRIORITY = "optional"
4 HOMEPAGE = "http://www.mplayerhq.hu/"
5 DEPENDS = "virtual/libsdl libmad zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11"
6 RDEPENDS = "mplayer-common"
7 LICENSE = "GPL"
8 SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-1.0rc1.tar.bz2 \
9            file://vo_w100.c \
10            file://vo_w100_api.h \
11            file://vo_w100_fb.h \
12            file://vo_pxa.c \
13            file://vo_pxa.h \
14            file://Makefile.patch;patch=1 \
15            file://w100-configure.patch;patch=1 \
16            file://w100-Makefile.patch;patch=1 \
17            file://w100-video_out.patch;patch=1 \
18            file://w100-mplayer.patch;patch=1 \
19            file://pld-onlyarm5.patch;patch=1 \
20            file://makefile-nostrip.patch;patch=1 \
21            ${SOURCEFORGE_MIRROR}/libw100/mplayer-imageon.patch;patch=1 \
22            file://imageon-video_out.patch;patch=1 \
23            file://powerpc-is-ppc.diff;patch=1 \
24            file://pxa_configure.patch;patch=1 \
25            file://pxa-video_out.patch;patch=1 \
26           "
27
28 SRC_URI_append_avr32 = " file://mplayer-1.0rc1-atmel.2.patch;patch=1 \
29                        "
30
31 # This is required for the collie machine only as all stacks in that
32 # machine seem to be set to executable by the toolchain. If someone
33 # discovers this is more general than please make this more general
34 # ie. for all armv4 machines.
35 SRC_URI_append_collie = "file://disable-executable-stack-test.patch;patch=1"
36 PACKAGE_ARCH_mplayer_collie = "collie"
37 PACKAGE_ARCH_mencoder_collie = "collie"
38
39 RCONFLICTS_${PN} = "mplayer-atty"
40 RREPLACES_${PN} = "mplayer-atty"
41 PR = "r15"
42
43 PARALLEL_MAKE = ""
44
45 DEPENDS_append_c7x0 = " sharp-aticore-oss libw100 "
46 DEPENDS_append_hx4700 = " libw100 "
47
48 S = "${WORKDIR}/MPlayer-1.0rc1"
49
50 PACKAGES =+ "mencoder"
51
52 FILES_${PN} = "${bindir}/mplayer ${libdir}"
53 FILES_mencoder = "${bindir}/mencoder"
54
55 inherit autotools pkgconfig
56
57 EXTRA_OECONF = " \
58         --prefix=/usr \
59         --mandir=${mandir} \
60         --target=${TARGET_SYS} \
61         \
62         --enable-mencoder \
63         --disable-gui \
64         --enable-largefiles \
65         --disable-linux-devfs \
66         --disable-lirc \
67         --disable-lircc \
68         --disable-joystick \
69         --disable-vm \
70         --disable-xf86keysym \
71         --disable-tv \
72         --disable-tv-v4l2 \
73         --disable-tv-bsdbt848 \
74         --enable-rtc \
75         --enable-network \
76         --disable-winsock2 \
77         --disable-smb \
78         --disable-live \
79         --disable-dvdread \
80         --disable-mpdvdkit \
81         --disable-cdparanoia \
82         --enable-freetype \
83         --disable-unrarlib \
84         --disable-menu \
85         --enable-sortsub \
86         --disable-fribidi \
87         --disable-enca \
88         --disable-macosx \
89         --disable-macosx-finder-support \
90         --disable-macosx-bundle \
91         --disable-ftp \
92         --disable-vstream \
93         \
94         --disable-gif \
95         --enable-png \
96         --enable-jpeg \
97         --disable-libcdio \
98         --enable-liblzo \
99         --disable-win32 \
100         --disable-qtx \
101         --disable-xanim \
102         --disable-real \
103         --disable-xvid \
104         --disable-x264 \
105         \
106         --disable-libavutil_so \
107         --disable-libavcodec_so \
108         --disable-libavformat_so \
109         --disable-libpostproc_so \
110         --disable-libfame \
111         \
112         --enable-tremor-low \
113         \
114         --disable-speex \
115         --disable-theora \
116         --disable-faac \
117         --disable-ladspa \
118         --disable-libdv \
119         --enable-mad \
120         --disable-toolame \
121         --disable-twolame \
122         --disable-xmms \
123         --disable-mp3lib \
124         --disable-libdts \
125         --enable-libmpeg2 \
126         --disable-musepack \
127         --disable-amr_nb \
128         --disable-amr_nb-fixed \
129         --disable-amr_wb \
130         \
131         --disable-gl \
132         --disable-dga \
133         --disable-vesa \
134         --disable-svga \
135         --enable-sdl \
136         --disable-aa \
137         --disable-caca \
138         --disable-ggi \
139         --disable-ggiwmh \
140         --disable-directx \
141         --disable-dxr2 \
142         --disable-dxr3 \
143         --disable-dvb \
144         --disable-dvbhead \
145         --disable-mga \
146         --disable-xmga \
147         --enable-xv \
148         --disable-xvmc \
149         --disable-vm \
150         --disable-xinerama \
151         --enable-x11 \
152         --enable-fbdev \
153         --disable-mlib \
154         --disable-3dfx \
155         --disable-tdfxfb \
156         --disable-s3fb \
157         --disable-directfb \
158         --disable-zr \
159         --disable-bl \
160         --disable-tdfxvid \
161         --disable-tga \
162         --disable-pnm \
163         --disable-md5sum \
164         \
165         --enable-alsa \
166         --enable-ossaudio \
167         --disable-arts \
168         --disable-esd \
169         --disable-polyp \
170         --disable-jack \
171         --disable-openal \
172         --disable-nas \
173         --disable-sgiaudio \
174         --disable-sunaudio \
175         --disable-win32waveout \
176         --enable-select \
177         \
178         --disable-runtime-cpudetection \
179         "
180
181 EXTRA_OECONF_append_arm = " --disable-decoder=vorbis_decoder \
182                             --disable-encoder=vorbis_encoder"
183
184 EXTRA_OECONF_append_progear = " --disable-sse --disable-3dnow --disable-mmxext --disable-sse2"
185
186 #enable support for the ati imageon series (w100 and w3220)
187 EXTRA_OECONF_append_c7x0 = " --enable-w100 "
188 EXTRA_OECONF_append_hx4700 = " --enable-imageon "
189
190 #enable pxa270 overlay support
191 EXTRA_OECONF_append_spitz = " --enable-pxa "
192 EXTRA_OECONF_append_akita = " --enable-pxa "
193 EXTRA_OECONF_append_a780 = " --enable-pxa "
194 EXTRA_OECONF_append_magician = " --enable-pxa "
195 EXTRA_OECONF_append_htcuniversal = " --enable-pxa "
196 EXTRA_OECONF_append_palmld = " --enable-pxa "
197
198 #build with support for the iwmmxt instruction support (pxa270 and up)
199 TARGET_CC_ARCH_spitz = "-march=iwmmxt -mtune=iwmmxt"
200 PACKAGE_ARCH_spitz = "iwmmxt"
201 TARGET_CC_ARCH_akita = "-march=iwmmxt -mtune=iwmmxt"
202 PACKAGE_ARCH_akita = "iwmmxt"
203 TARGET_CC_ARCH_a780 = "-march=iwmmxt -mtune=iwmmxt"
204 PACKAGE_ARCH_a780 = "iwmmxt"
205 TARGET_CC_ARCH_hx4700 = "-march=iwmmxt -mtune=iwmmxt"
206 PACKAGE_ARCH_hx4700 = "iwmmxt"
207 TARGET_CC_ARCH_magician = "-march=iwmmxt -mtune=iwmmxt"
208 PACKAGE_ARCH_magician = "iwmmxt"
209 TARGET_CC_ARCH_htcuniversal = "-march=iwmmxt -mtune=iwmmxt"
210 PACKAGE_ARCH_htcuniversal = "iwmmxt"
211 TARGET_CC_ARCH_palmld = "-march=iwmmxt -mtune=iwmmxt"
212 PACKAGE_ARCH_palmld = "iwmmxt"
213
214 do_configure() {
215         cp ${WORKDIR}/vo_w100.c ${S}/libvo
216         cp ${WORKDIR}/vo_w100_api.h ${S}/libvo
217         cp ${WORKDIR}/vo_w100_fb.h ${S}/libvo
218     cp ${WORKDIR}/vo_pxa.c ${S}/libvo
219     cp ${WORKDIR}/vo_pxa.h ${S}/libvo
220
221         sed -i 's|/usr/include|${STAGING_INCDIR}|g' ${S}/configure
222         sed -i 's|/usr/lib|${STAGING_LIBDIR}|g' ${S}/configure
223         sed -i 's|/usr/\S*include[\w/]*||g' ${S}/configure
224         sed -i 's|/usr/\S*lib[\w/]*||g' ${S}/configure
225
226         ./configure ${EXTRA_OECONF}
227 }
228
229 do_compile () {
230         oe_runmake
231 }
232