merge of '45fb4fa94d52a65c3a3fa636c6122139173dfa8d'
[vuplus_openembedded] / packages / mozilla / firefox_2.0.bb
1 PR = "r1"
2 SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
3         file://xptcstubs.patch;patch=1 \
4         file://no-xmb.patch;patch=1 \
5         file://jsautocfg.h \
6         file://extensions-hack.patch;patch=1 \
7     file://security-cross.patch;patch=1 \
8     file://jsautocfg-dontoverwrite.patch;patch=1"
9
10 S = "${WORKDIR}/mozilla"
11 DEFAULT_PREFERENCE = "-1"
12
13 inherit mozilla
14
15 require firefox.inc
16
17 do_compile_prepend() {
18         cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
19
20         sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
21 }
22
23 do_stage() {
24
25         install -d ${STAGING_INCDIR}/${P}
26         cd dist/sdk/include
27         headers=`find . -name "*.h"`
28         for f in $headers
29         do
30                 install -m 0644 $f ${STAGING_INCDIR}/${P}/$f
31         done
32         # removes 2 lines that call absent headers
33         sed -e '178,179d' ${STAGING_INCDIR}/${P}/nsIServiceManager.h
34 }
35