iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / meta / slugos-packages.bb
1 # Meta package containing all the packages which build for SlugOS
2 #
3 # All packages in here must build with the slugos-???.conf distros,
4 # they do not necessarily work.
5 DESCRIPTION = "Packages that are compatible with the SlugOS firmware"
6 HOMEPAGE = "http://www.nslu2-linux.org"
7 LICENSE = "MIT"
8 PR = "r54"
9 CONFLICTS = "db3"
10
11 COMPATIBLE_MACHINE = "nslu2|ixp4xx"
12 EXCLUDE_FROM_WORLD = "1"
13 INHIBIT_DEFAULT_DEPS = "1"
14 ALLOW_EMPTY = "1"
15
16 # The list of packages to build for the slugos DISTRO.
17 # KEEP IN ALPHABETICAL ORDER
18 # Do *not* simply comment out a line. That will break. Instead
19 # remove the package and place it in the corresponding "broken" list
20
21 SLUGOS_PACKAGES = "\
22         alsa-lib \
23         alsa-utils \
24         apex-env \
25         apr \
26         asterisk \
27         asterisk-core-sounds-en-alaw \
28         asterisk-core-sounds-en-g729 \
29         asterisk-core-sounds-en-gsm \
30         asterisk-core-sounds-en-ulaw \
31         asterisk-extra-sounds-en-alaw \
32         asterisk-extra-sounds-en-g729 \
33         asterisk-extra-sounds-en-gsm \
34         asterisk-extra-sounds-en-ulaw \
35         asterisk-moh-freeplay-alaw \
36         asterisk-moh-freeplay-g729 \
37         asterisk-moh-freeplay-gsm \
38         asterisk-moh-freeplay-ulaw \
39         atftp \
40         audiofile \
41         aumix \
42         autoconf \
43         autofs \
44         automake \
45         bash \
46         beep \
47         bind \
48         binutils \
49         bison \
50         bluez-utils \
51         bluez-hcidump \
52         bogofilter \
53         bonnie++ \
54         boost \
55         bridge-utils \
56         bzip2 \
57         ccxstream \
58         cdparanoia \
59         cdstatus \
60         cherokee \
61         coreutils \
62         cron \
63         cryptsetup \
64         ctorrent \
65         ctrlproxy \
66         cups \
67         curl \
68         cvs \
69         cyrus-imapd \
70         cyrus-sasl \
71         db \
72         devio \
73         devlabel \
74         diffstat \
75         diffutils \
76         dircproxy \
77         dnsmasq \
78         dropbear \
79         e2fsprogs \
80         e2fsprogs-libs \
81         expat \
82         ez-ipupdate \
83         fconfig \
84         file \
85         findutils \
86         fis \
87         flac \
88         flex \
89         flite \
90         ftpd-topfield \
91         fuse \
92         gawk \
93         gcc \
94         gdb \
95         gdbm \
96         glib-2.0 \
97         gnu-config \
98         gphoto2 \
99         gpsd \
100         grep \
101         groff \
102         gtk-doc \
103         gzip \
104         hdparm \
105         hostap-daemon \
106         ifupdown \
107         inetutils \
108         iozone3 \
109         iperf \
110         ipkg-utils \
111         iptables \
112         ircp \
113         irssi \
114         joe \
115         jpeg \
116         kexec-tools \
117         lcdproc \
118         less \
119         libao \
120         libdvb \
121         libexif \
122         libid3tag \
123         liblockfile \
124         libmad \
125         libmikmod \
126         libogg \
127         libol \
128         libpam \
129         libpcre \
130         libpng \
131         libtool \
132         libupnp \
133         libusb \
134         libvorbis \
135         libxml2 \
136         lighttpd \
137         linphone \
138         litestream \
139         logrotate \
140         lrzsz \
141         lsof \
142         lvm2 \
143         m4 \
144         madplay \
145         madwifi-ng \
146         mailx \
147         make \
148         man man-pages \
149         masqmail \
150         mdadm \
151         mediatomb \
152         memtester \
153         mgetty \
154         miau \
155         microcom \
156         minicom \
157         monit \
158         mpd \
159         mt-daapd \
160         mtd-utils \
161         mutt \
162         mysql \
163         nail \
164         nano \
165         ncftp \
166         ncurses \
167         net-tools \
168         netatalk \
169         netcat \
170         netpbm \
171         nfs-utils \
172         ngrep \
173         nmap \
174         ntfs-3g \
175         ntp \
176         ntpclient \
177         obexftp \
178         obexpush \
179         openobex-apps \
180         openntpd \
181         openobex \
182         openocd \
183         openssh \
184         openvpn \
185         patch \
186         pciutils \
187         perl \
188         picocom \
189         pkgconfig \
190         popt \
191         portmap \
192         postfix \
193         ppp \
194         procps \
195         psmisc \
196         puppy \
197         pvrusb2-mci \
198         python \
199         quilt \
200         reiserfsprogs reiser4progs \
201         rng-tools \
202         rsync \
203         rtorrent \
204         samba \
205         sane-backends \
206         screen \
207         sed \
208         setpwc \
209         setserial \
210         sipsak \
211         slugimage \
212         smartmontools \
213         spandsp \
214         sqlite \
215         squid \
216         ssmtp \
217         strace \
218         streamripper \
219         stunnel \
220         sudo \
221         sysfsutils \
222         tar \
223         task-mokogateway-everything \
224         tcpdump \
225         thttpd \
226         tiff \
227         tzdata \
228         unrar \
229         unzip \
230         upslug2 \
231         usbutils \
232         ushare \
233         util-linux \
234         vim \
235         vlan \
236         vsftpd \
237         w3cam \
238         wakelan \
239         watchdog \
240         webcam-server \
241         wget \
242         wireless-tools \
243         wireshark \
244         wpa-supplicant \
245         wview-sim \
246         wview-vpro \
247         wview-wxt510 \
248         xinetd \
249         yeaphone \
250         yp-tools ypbind ypserv \
251         zd1211-firmware \
252         zip \
253         zlib \
254         "
255
256 # Packages currently broken on all platforms
257 SLUGOS_BROKEN_PACKAGES = "\
258         bwmon \
259         dsniff \
260         eciadsl \
261         fetchmail \
262         gspcav1 \
263         lirc-modules lirc \
264         madfu \
265         motion \
266         openldap \
267         pwc \
268         qc-usb-messenger \
269         syslog-ng \
270         task-native-sdk \
271         unionfs-modules unionfs-utils \
272         wview-sim-mysql wview-wxt510-mysql wview-vpro-mysql \
273         zd1211 \
274         "
275
276 SLUGOS_EXTRA_PACKAGES ?= ""
277
278 # The package-index at the end causes regeneration of the Packages.gz and
279 # other control files.
280 DEPENDS = "\
281         slugos-image \
282         slugos-native \
283         task-nas-server-everything \
284         task-proper-tools \
285         ${SLUGOS_PACKAGES} \
286         ${SLUGOS_EXTRA_PACKAGES} \
287         package-index \
288         "
289
290 inherit meta
291
292 do_package_write_ipk() {
293 }