Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / meta / oplinux-packages.bb
1 # Meta package containing all the packages which build for OPLinux and OPLinux uclibc distro
2 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4 DESCRIPTION = "Packages that are compatible with the OPLinux distro"
5 HOMEPAGE = "http://www.digital-opsis/oplinux"
6 LICENSE = "MIT"
7 PR = "r2"
8 PROVIDES += "${OPLINUX_IMAGENAME}-packages"
9
10 EXCLUDE_FROM_WORLD = "1"
11 INHIBIT_DEFAULT_DEPS = "1"
12 ALLOW_EMPTY = "1"
13
14
15 python __anonymous () {
16
17     import bb
18
19    #Get all the packages we can build/exist in OE
20     package_list =  bb.data.getVar('PACKAGES_LIST', d) or "none"
21     package_list=package_list.split()
22
23    #Get the packages that are broken on all architectures
24     broken_package_list =  bb.data.expand('${OPLINUX_BROKEN_PACKAGES}', d)
25
26    # Get the arch we are building for
27     building_arch = bb.data.getVar('FEED_ARCH',d) 
28
29    #Now add the broken packages list the ones that fail for the arch we build now
30     if (building_arch=="i486") or (building_arch=="i586") or (building_arch=="i686"):
31        broken_package_list = broken_package_list + bb.data.expand('${OPLINUX_BROKEN_PACKAGES_ARCH_x86}', d)
32
33     elif  (building_arch=="ppc405"):
34            broken_package_list = broken_package_list + bb.data.expand('${OPLINUX_BROKEN_PACKAGES_ARCH_PPC}', d)
35
36     elif (building_arch=="ppc603e"):       
37            broken_package_list = broken_package_list + bb.data.expand('${OPLINUX_BROKEN_PACKAGES_ARCH_POWERPC}', d)
38
39
40     for chk_package in package_list :
41         build_package="yes"
42         if chk_package in broken_package_list:
43            build_package="no"
44         else :
45               bb.data.setVar('DEPENDS', (bb.data.getVar('DEPENDS', d) + chk_package +" "), d)   
46
47 #add the OPLinux extra packages to the DEPENDS list
48     bb.data.setVar('DEPENDS', (bb.data.getVar('DEPENDS', d) + bb.data.getVar('OPLINUX_EXTRA_PACKAGES', d)), d)   
49
50
51     bb.data.setVar('DEPENDS', (bb.data.getVar('DEPENDS', d) + "package-index"), d)   
52 }
53
54
55
56
57
58 # The list of packages availiable to OE 
59 # KEEP IN ALPHABETICAL ORDER
60 # Do *not* simply comment out a line. That will break. Instead
61 # remove the package and place it in the corresponding "broken" list
62 PACKAGES_LIST = "\
63         acct \
64         acpid \
65         adns \
66         aiostress \
67         aircrack \
68         alsa-lib \
69         alsa-utils \
70         apache2 \
71         appweb \
72         apmd \
73         apt \
74         ark3116 \
75         arpwatch \
76         at       \
77         atd \
78         atftp \
79         atmelwlandriver \ 
80         audiofile \
81         aumix \
82         autoconf \
83         automake \
84         autofs \
85         aspell \
86         avahi \
87         bacula-client \
88         balsa \
89         bash \
90         bazaar \
91         bb \
92         bc \
93         beep \
94         beecrypt \ 
95         beepmp \
96         bind \
97         binutils \
98         bing \
99         bison \
100         bitchx \
101         blueprobe \
102         bmon \
103         boa \ 
104         bochs \
105         bogofilter \
106         boost \      
107         boost-asio \
108         bonnie++ \
109         bootchart \
110         bootmenu \
111         bootsplash \
112         bridge-utils \
113         bt950-cs \
114         btscanner \
115         btsco \
116         btsco-module \
117         btxml \
118         bvi \
119         bwmon \
120         bluez-utils \
121         bzflag \
122         bzflag-server \
123         bzip2 \
124         came \
125         chillispot \
126         camsource \
127         cscope \
128         cups \
129         ccxstream \
130         cdparanoia \
131         cdstatus \
132         cetools \
133         cherokee \
134         ckermit \
135         clish \
136         coreutils \
137         conserver \
138         corkscrew \
139         cpusage \
140         cron \
141         ctorrent \
142         cvs \
143         cyrus-sasl \
144         cyrus-imapd \
145         dialog \
146         db \
147         ddclient \
148         dhclient \
149         dhcp \
150         didiwiki \
151         devlabel \
152         diffstat \
153         diffutils \
154         dnsmasq \
155         ebtables \
156         elftoaout \
157         emul \
158         enscript \
159         e2fsprogs \
160         e2fsprogs-libs \
161         esmtp \
162         etherpuppet \
163         ethload \
164         ethtool \
165         ettercap \
166         expat \
167         ez-ipupdate \
168         fortune-mod \
169         fakeconnect \
170         fbgrab \
171         fetchmail \
172         file \
173         findutils \
174         flac \
175         flex \
176         flite \
177         frotz \
178         fush \
179         g15daemon \
180         gallery \
181         gammu \
182         gawk \
183         gcc \
184         gdb \
185         gdbm \
186         genext2fs \
187         gphoto2 \
188         git \
189         gift \
190         glib-2.0 \
191         gpm \
192         gpsbabel \
193         gs \
194         gnu-config \
195         gnuplot \
196         gpsd \
197         grep \
198         gtk-doc \
199         gzip \
200         hdparm \
201         hydra \
202         ifupdown \
203         iputils \
204         ipkg-utils \
205         iptables \
206         intercom \
207         ircp \
208         irssi \
209         joe \
210         jpeg \
211         kismet \
212         kbdd \
213         ksymoops \
214         lame \
215         lxt \
216         lcdproc \
217         less \
218         libao \
219         libpcre \
220         libid3tag \
221         liblockfile \
222         libmad \
223         libmikmod \
224         libogg \
225         libol \
226         libpng \
227         libtool \
228         libupnp \
229         libusb \
230         libvorbis \
231         litestream \
232         lrzsz \
233         lsof \
234         lvm2 \
235         m4 \
236         madplay \
237         mailx \
238         make \
239         mc \
240         mikmod \
241         mdadm \
242         memtester \
243         mgetty \
244         miau \
245         microcom \
246         minicom \
247         modphp \
248         modplugplay \
249         mp3blaster \
250         mpg321 \
251         mt-daapd \
252         mtd-utils \
253         mutt \
254         mysql \
255         mystun-server \
256         nail \
257         nano \
258         ncftp \
259         ncurses \
260         netcat \
261         nmap \
262         nmixer \
263         ntp \
264         netkit-ftp \
265         netperf \
266         net-snmp \
267         nfs-utils \
268         ngrep \
269         nmap \
270         nsd \
271         ntp \
272         ntpdate \
273         openobex-apps \
274         openldap \
275         openntpd \
276         openobex \
277         obexftp \
278         obexpush \
279         olsrd \
280         openswan \
281         openssh \
282         openvpn \
283         patch \
284         pciutils \
285         pcmcia-cs \        
286         portmap \
287         privoxy \
288         perl \
289         pkgconfig \
290         ppp \
291         procps \
292         pvrusb2-mci \
293         pwc \
294         quilt \
295         rng-tools \
296         rsync \
297         samba \
298         sane-backends \
299         sed \
300         setpwc \
301         setserial \
302         shorewall \
303         smartmontools \
304         ssmtp \
305         strace \
306         streamripper \
307         sysfsutils \
308         syslog-ng \
309         stunnel \
310         spandsp \
311         subversion \
312         slutils \
313         strace \
314         sudo \
315         tcpdump \
316         tor \
317         tar \
318         thttpd \
319         tiff \
320         texinfo \
321         unzip \
322         unrar \ 
323         usbutils \
324         util-linux \
325         vim \
326         vlan \
327         vorbis-tools \
328         vpnc \
329         vsftpd \
330         vtun \
331         watchdog \
332         wget \
333         zd1211-firmware \
334         zip \
335         zlib \
336         zsh \
337         lirc \
338         masqmail \
339         wakelan \
340         wireless-tools \
341         wpa-supplicant \
342         libxml2 \
343         libdvb \
344         madwifi-ng \
345         motion \
346         ftpd-topfield \
347         eciadsl \
348         netpbm \
349         reiserfsprogs reiser4progs \
350         python \
351         mpd \
352         memtester \
353         puppy \
354
355         ctrlproxy \
356         dsniff \    
357         iperf \
358         groff \
359         man man-pages \
360         psmisc \
361         screen \
362         tzdata \
363         wview-sim wview-vpro wview-wxt510 \
364         wview-sim-mysql wview-vpro-mysql \
365         wview-wxt510-mysql \
366         xinetd \
367         obexftp \
368         qc-usb-messenger \
369         unionfs-modules \
370         unionfs-utils \
371         erlang \
372         ctrlproxy \
373         dsniff \    
374         fortune-mod \
375         libpam \
376         nfs-utils \
377         rng-tools \
378         postfix \
379         yp-tools ypbind ypserv \
380  
381 "
382
383
384
385 # Packages currently broken on all platforms (glibc)
386 OPLINUX_BROKEN_PACKAGES = "irssi \
387         unionfs-modules \
388         unionfs-utils \
389
390 "
391
392 #Here we define the packages that are broken on a specific architecture
393 #i486, i586, i686
394 OPLINUX_BROKEN_PACKAGES_ARCH_x86 =" \
395         aircrack \
396         appweb \
397         apt \
398         ark3116 \
399         at \
400         atmelwlandriver \ 
401         atftp \
402         autofs \
403         balsa \
404         bazaar \
405         bb \
406         beecrypt \
407         beepmp \
408         bitchx \
409         bochs \
410         bmon \
411         bt950-cs \
412         btscanner \
413         btsco-module \
414         bwmon \
415         came \
416         ctrlproxy \
417         cyrus-sasl \
418         cyrus-imapd \
419         dsniff \    
420         eciadsl \
421         erlang \
422         fortune-mod \
423         gphoto2 \
424         gpsd   \
425         intercom \
426         lcdproc  \
427         lirc \
428         mpd \
429         puppy \
430         pvrusb2-mci \
431         pwc \
432         qc-usb-messenger \
433         sane-backends \
434         setpwc \
435         slutils \
436         texinfo \
437         vsftpd \
438         libpam \
439         aircrack \
440         appweb \
441         apt \
442         ark3116 \
443         gcc \
444         gpsd \
445         pvrusb2-mci \
446         pwc \
447         setpwc \
448         cyrus-sasl \
449         atftp \
450         gphoto2 \
451         lirc \
452         libdvb \
453         netpbm \
454 "
455 #
456 #ppc405
457 OPLINUX_BROKEN_PACKAGES_ARCH_PPC = " \
458         aircrack \
459         appweb \
460         apt \
461         ark3116 \
462         at \
463         atmelwlandriver \ 
464         atftp \
465         autofs \
466         balsa \
467         bazaar \
468         bb \
469         beecrypt \
470         beepmp \
471         bitchx \
472         bochs \
473         bmon \
474         bt950-cs \
475         btscanner \
476         btsco-module \
477         bwmon \
478         came \
479         ctrlproxy \
480         cyrus-sasl \
481         cyrus-imapd \
482         dsniff \    
483         eciadsl \
484         erlang \
485         fortune-mod \
486         gphoto2 \
487         gpsd   \
488         intercom \
489         lcdproc  \
490         lirc \
491         mpd \
492         puppy \
493         pvrusb2-mci \
494         pwc \
495         qc-usb-messenger \
496         sane-backends \
497         setpwc \
498         slutils \
499         texinfo \
500         vsftpd \
501 "
502
503
504
505 #
506 #ppc440 ppc603e
507 OPLINUX_BROKEN_PACKAGES_ARCH_POWERPC = " \
508         aircrack \
509         appweb \
510         apt \
511         ark3116 \
512         arpwatch \
513         at \
514         atmelwlandriver \ 
515         atftp \
516         autofs \
517         balsa \
518         bazaar \
519         bb \
520         beecrypt \
521         beepmp \
522         bitchx \
523         bochs \
524         bmon \
525         bt950-cs \
526         btscanner \
527         btsco-module \
528         bwmon \
529         came \
530         ctrlproxy \
531         cyrus-sasl \
532         cyrus-imapd \
533         dsniff \    
534         eciadsl \
535         erlang \
536         fortune-mod \
537         gphoto2 \
538         gpsd   \
539         intercom \
540         lcdproc  \
541         lirc \
542         mpd \
543         puppy \
544         pvrusb2-mci \
545         pwc \
546         qc-usb-messenger \
547         sane-backends \
548         setpwc \
549         slutils \
550         spandsp \
551         texinfo \
552         vsftpd \
553
554         libpam \
555         aircrack \
556         appweb \
557         apt \
558         ark3116 \
559         gcc \
560         gpsd \
561         pvrusb2-mci \
562         pwc \
563         setpwc \
564         cyrus-sasl \
565         atftp \
566         gphoto2 \
567         lirc \
568         libdvb \
569         netpbm \
570 "
571
572
573
574
575 #Packages broken per machine (if we ever need such a thing)
576 OPLINUX_BROKEN_PACKAGES_append_x86 =" \
577 "
578 OPLINUX_BROKEN_PACKAGES_append_i586-generic =" \
579 "
580 OPLINUX_BROKEN_PACKAGES_append_i686-generic =" \
581 "
582 OPLINUX_BROKEN_PACKAGES_append_epia =" \
583 "
584 OPLINUX_BROKEN_PACKAGES_append_wrap = "\
585 "
586
587 #ppc targets
588 OPLINUX_BROKEN_PACKAGES_append_magicbox = "\
589 "
590 OPLINUX_BROKEN_PACKAGES_append_dht-walnut = "\
591 "
592 #powerpc targets
593 OPLINUX_BROKEN_PACKAGES_append_efika = "\
594 "
595
596
597 #
598 #
599 OPLINUX_UCLIBC_UNSUPPORTABLE_PACKAGES = "\
600         libpam \
601         nfs-utils \
602         rng-tools \
603         postfix \
604         yp-tools ypbind ypserv \
605         "
606
607 # These packages work with glibc, but break on uclibc.
608 OPLINUX_UCLIBC_BROKEN_PACKAGES = "\
609 #       bwmon \
610 #       erlang \
611 #       apr \
612 #       bogofilter \
613 #       boost \
614 #       linphone \
615 #       sudo \
616 #       ushare \
617         "
618
619 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_x86 = "\
620         "
621
622 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_epia = "\
623         "
624
625 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_wrap = "\
626         "
627
628 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_magicbox = "\
629         "
630
631 OPLINUX_UCLIBC_BROKEN_PACKAGES_append_dht-walnut = "\
632         "
633
634
635 # Packages which build only with glibc (some of these use internal
636 # glibc functions and so will probably never run on uclibc).
637 OPLINUX_BROKEN_PACKAGES_append_uclibc-linux = "\
638         ${OPLINUX_UCLIBC_UNSUPPORTABLE_PACKAGES} \
639         ${OPLINUX_UCLIBC_BROKEN_PACKAGES} \
640
641 "
642
643 #
644 #Any extra packages defined 
645 #
646 OPLINUX_EXTRA_PACKAGES ?= ""