removal.txt: remove familiar-unstable.conf from the list of removals. This has been...
[vuplus_openembedded] / packages / meta / openprotium-packages.bb
1 # Meta package containing all the packages which build for SlugOS
2 #
3 # All packages in here must build with the slugos-???.conf distros,
4 # they do not necessarily work.
5 DESCRIPTION = "Packages that are compatible with the Openprotium on the iomega Storcenter"
6 HOMEPAGE = "http://www.openprotium.org"
7 LICENSE = "MIT"
8 PR = "r1"
9 CONFLICTS = "db3"
10 PROVIDES += "${OPENPROTIUM_IMAGENAME}-packages"
11
12 EXCLUDE_FROM_WORLD = "1"
13 INHIBIT_DEFAULT_DEPS = "1"
14 ALLOW_EMPTY = "1"
15
16 # The list of packages to build for the slugos DISTRO.
17 # KEEP IN ALPHABETICAL ORDER
18 # Do *not* simply comment out a line. That will break. Instead
19 # remove the package and place it in the corresponding "broken" list
20
21 # deleted from "base" as they don't immediately build...
22 #       asterisk \
23 #       asterisk-sounds \
24 #       beep \
25 #       cherokee \
26 #       cyrus-sasl \
27 #       atftp \
28 #       flac \
29 #       gphoto2 \
30 #       gdb \
31 #       glib-2.0 \
32 #       lirc \
33 #       masqmail \
34 #       wakelan \
35 #       wireless-tools \
36 #       wpa-supplicant \
37 #       madwifi-ng \
38 #       motion \
39 #       netpbm \
40 #       reiserfsprogs reiser4progs \
41 #       mpd \
42
43 OPENIOM_PACKAGES = "\
44         alsa-lib \
45         alsa-utils \
46         audiofile \
47         aumix \
48         autoconf \
49         automake \
50         bash \
51         bind \
52         binutils \
53         bison \
54         bluez-utils-nodbus \
55         bridge-utils \
56         bzip2 \
57         ccxstream \
58         cdparanoia \
59         cdstatus \
60         coreutils \
61         cron \
62         ctorrent \
63         cvs \
64         db \
65         devlabel \
66         diffstat \
67         diffutils \
68         dnsmasq \
69         e2fsprogs \
70         e2fsprogs-libs \
71         eciadsl \
72         expat \
73         ez-ipupdate \
74         fetchmail \
75         file \
76         findutils \
77         flex \
78         flite \
79         ftpd-topfield \
80         gawk \
81         gcc \
82         gdbm \
83         gnu-config \
84         grep \
85         gtk-doc \
86         gzip \
87         hdparm \
88         ifupdown \
89         ipkg-utils \
90         iptables \
91         ircp \
92         joe \
93         jpeg \
94         lcdproc \
95         less \
96         libao \
97         libdvb \
98         libgphoto2 \
99         libid3tag \
100         liblockfile \
101         libmad \
102         libmikmod \
103         libogg \
104         libol \
105         libpng \
106         libtool \
107         libupnp \
108         libusb \
109         libvorbis \
110         libxml2 \
111         litestream \
112         lrzsz \
113         lsof \
114         lvm2 \
115         m4 \
116         madplay \
117         mailx \
118         make \
119         mdadm \
120         memtester \
121         mgetty \
122         miau \
123         microcom \
124         minicom \
125         mt-daapd \
126         mtd-utils \
127         mutt \
128         nail \
129         nano \
130         ncftp \
131         ncurses \
132         netcat \
133         nmap \
134         ntp \
135         openobex-apps \
136         openldap \
137         openntpd \
138         openobex \
139         openssh \
140         openvpn \
141         patch \
142         pciutils \
143         libpcre \
144         perl \
145         pkgconfig \
146         ppp \
147         procps \
148         puppy \
149         pvrusb2-mci \
150         pwc \
151         python \
152         quilt \
153         rng-tools \
154         rsync \
155         samba \
156         sane-backends \
157         sed \
158         setpwc \
159         setserial \
160         smartmontools \
161         ssmtp \
162         strace \
163         streamripper \
164         sysfsutils \
165         syslog-ng \
166         tar \
167         thttpd \
168         tiff \
169         unzip \
170         usbutils \
171         util-linux \
172         vim \
173         vlan \
174         vsftpd \
175         watchdog \
176         wget \
177         zd1211 \
178         zip \
179         zlib \
180         "
181
182 # Packages currently broken on all platforms
183 SLUGOS_BROKEN_PACKAGES = "\
184         irssi \
185         obexftp \
186         qc-usb-messenger \
187         unionfs-modules \
188         unionfs-utils \
189         icecast \
190         cyrus-imapd \
191         "
192
193 # These packages will never build because uclibc lacks (and always will lack)
194 # appropriate support.  This define is for documentation of this fact!  The
195 # normal cause is that the package uses the "NIS" interfaces (once known as
196 # YP - a trademark of BT which SUN used without license - the missing function
197 # calls often still have 'yp' in the name).
198
199 # NOTE: rng-tools is only here until argp-standalone can be built!
200 UCLIBC_UNSUPPORTABLE_PACKAGES = "\
201         libpam \
202         nfs-utils \
203         rng-tools \
204         postfix \
205         yp-tools ypbind ypserv \
206         "
207
208 # These packages work with glibc, but break on uclibc.
209 UCLIBC_BROKEN_PACKAGES = "\
210         apr \
211         bogofilter \
212         boost \
213         bwmon \
214         erlang \
215         linphone \
216         sudo \
217         ushare \
218         "
219
220 # Packages which build only with glibc (some of these use internal
221 # glibc functions and so will probably never run on uclibc).
222 SLUGOS_PACKAGES_append_linux = "\
223         ${UCLIBC_UNSUPPORTABLE_PACKAGES} \
224         ${UCLIBC_BROKEN_PACKAGES} \
225         ctrlproxy \
226         dsniff \
227         iperf \
228         groff \
229         man man-pages \
230         psmisc \
231         screen \
232         timezones \
233         wview-sim wview-vpro wview-wxt510 \
234         wview-sim-mysql wview-vpro-mysql \
235         wview-wxt510-mysql \
236         xinetd \
237         "
238
239 SLUGOS_PACKAGES_append_linux-uclibc = "\
240         "
241
242 # These packages are not in the build because they have a significant compilation
243 # time, add them to SLUGOS_EXTRA_PACKAGES if required
244 SLUGOS_OPTIONAL_PACKAGES = "\
245         mysql \
246         "
247
248 #
249 # you can place these in the top level openembedded/conf/distro/openprotium.conf
250 # file to fine-tune what's happening
251 #
252 OPENIOM_EXTRA_PACKAGES ?= ""
253
254 # The package-index at the end causes regeneration of the Packages.gz and
255 # other control files.
256 # openprotium-native \
257 DEPENDS = "\
258         openprotium-image \
259         ${OPENIOM_PACKAGES} \
260         ${OPENIOM_EXTRA_PACKAGES} \
261         package-index \
262         "