openmoko-session2: add RDEPENDS openmoko-panel-memory and oe-stylize
[vuplus_openembedded] / packages / meta / external-toolchain.bb
1 DESCRIPTION = "This package allows OE to work with an external toolchain generated \
2                by meta-toolchain instead of building its own. It expects that toolchain \
3                to be located in SDK_PREFIX/prefix."
4
5 PROVIDES = "\
6     linux-libc-headers \
7     virtual/${TARGET_PREFIX}gcc \
8     virtual/${TARGET_PREFIX}gcc-initial \
9     virtual/${TARGET_PREFIX}binutils \
10     virtual/${TARGET_PREFIX}libc-for-gcc \
11     virtual/libc \
12     virtual/libintl \
13     virtual/libiconv \
14     glibc-thread-db \
15     "
16
17 RPROVIDES = "glibc-utils libsegfault glibc-thread-db libgcc-dev libstdc++-dev libstdc++"
18 PACKAGES_DYNAMIC = "glibc-gconv-*"
19 PR = "r1"
20
21 inherit sdk
22
23 do_stage() {
24         if [ ! -e  ${prefix}/package-status ]; then
25                 echo "The external toolchain could not be found in ${prefix}!"
26                 exit 1
27         fi
28         
29         install -d ${STAGING_DIR}/pkgdata/
30         install -d ${STAGING_DIR_TARGET}/shlibs/
31
32         cp -pPRr ${prefix}/pkgdata/* ${STAGING_DIR}/pkgdata/
33         cp -pPRr ${prefix}/${TARGET_SYS}/shlibs/* ${STAGING_DIR_TARGET}/shlibs/
34
35         if [ -d ${prefix}/ipk ]; then
36                 install -d ${DEPLOY_DIR_IPK}/
37                 cp -pPRr ${prefix}/ipk/* ${DEPLOY_DIR_IPK}/
38         fi
39
40         if [ -d ${prefix}/deb ]; then
41                 install -d ${DEPLOY_DIR_DEB}/
42                 cp -pPRr ${prefix}/deb/* ${DEPLOY_DIR_DEB}/
43         fi
44
45         if [ -d ${prefix}/pstage -a "x${DEPLOY_DIR_PSTAGE}" != "x" ]; then
46                 install -d ${DEPLOY_DIR_PSTAGE}/
47                 cp -pPRr ${prefix}/pstage/* ${DEPLOY_DIR_PSTAGE}/
48         fi
49 }