Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / memtester / memtester_4.0.5.bb
1 SECTION = "console/utils"
2 DESCRIPTION = "Utility to test for faulty memory subsystem"
3 LICENSE = "GPLv2"
4 FILE_PR = "r2"
5
6 SRC_URI = "http://pyropus.ca/software/memtester/old-versions/memtester-${PV}.tar.gz"
7 SRC_URI += "file://Makefile.patch;patch=1"
8
9 S = "${WORKDIR}/memtester-${PV}"
10
11 do_compile () {
12         echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
13         echo '${CC} ${LDFLAGS}' > conf-ld
14         oe_runmake
15 }
16
17 do_install () {
18         install -d ${D}${bindir}
19         install -d ${D}${mandir}/man8
20         install -m 0755 memtester ${D}${bindir}/
21         install -m 0755 memtester.8 ${D}${mandir}/man8/
22 }