Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / matchbox-sato / matchbox-sato_0.1.bb
1 DESCRIPTION = "Custom MB session files for poky"
2 LICENSE = "GPL"
3 SECTION = "x11"
4 RDEPENDS = "gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
5 RCONFLICTS = "matchbox-common"
6 PR = "r17"
7
8 SRC_URI = "file://etc file://matchbox-session"
9 S = ${WORKDIR}
10
11 do_install() {
12         install -d ${D}/${bindir}
13         install -m 0755 ${S}/matchbox-session ${D}/${bindir}
14         cp -R ${S}/etc ${D}/etc
15         rm -fR ${D}/etc/.svn
16         rm -fR ${D}/etc/matchbox/.svn
17         chmod -R 755 ${D}/etc
18 }
19
20 pkg_postinst_matchbox-sato () {
21 #!/bin/sh -e
22 if [ "x$D" != "x" ]; then
23     exit 1
24 fi
25
26 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
27 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato
28 gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
29 }