Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / matchbox-panel / matchbox-panel_0.9.1.bb
1 DESCRIPTION = "Matchbox Window Manager Panel"
2 LICENSE = "GPL"
3 DEPENDS = "libmatchbox virtual/libx11 libxext libxpm apmd startup-notification virtual/kernel"
4 SECTION = "x11/wm"
5 FILE_PR = "r2"
6
7 SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar.gz \
8            file://allow-100-per-cent-battery.patch;patch=1 \
9            file://no_time_support.patch;patch=1"
10
11 inherit autotools pkgconfig gettext
12
13 CFLAGS += "-D_GNU_SOURCE"
14
15 EXTRA_OECONF = "--enable-startup-notification --enable-dnotify"
16 EXTRA_OECONF_append_h3600 = " --enable-small-icons "
17 EXTRA_OECONF_append_h3900 = " --enable-small-icons "
18 EXTRA_OECONF_append_collie = " --enable-small-icons "
19 EXTRA_OECONF_append_poodle = " --enable-small-icons "
20 EXTRA_OECONF_append_ramses = " --enable-small-icons "
21
22
23 FILES_${PN} = "${bindir} \
24                ${datadir}/applications \
25                ${datadir}/pixmaps"
26