merge of '45fb4fa94d52a65c3a3fa636c6122139173dfa8d'
[vuplus_openembedded] / packages / man / man_1.5m2.bb
1 LICENSE = "GPL"
2 SECTION = "base"
3 DESCRIPTION = "The man page suite, including man, apropos, \
4 and whatis consists of programs that are used to read most \
5 of the documentation available on a Linux system."
6 RDEPENDS_${PN} = "less groff"
7 PR = "r1"
8
9 SRC_URI = "${KERNELORG_MIRROR}/gpub/linux/utils/man/man-${PV}.tar.bz2"
10
11 EXTRA_OEMAKE = ""
12 GS = "-DGREPSILENT=\"q\""
13 DEFS = "-DUSG -DDO_COMPRESS ${GS}"
14
15 do_configure() {
16         ./configure -d -confdir ${sysconfdir}
17 }
18
19 do_compile() {
20         (cd src; ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
21                 makemsg.c -o makemsg)
22         oe_runmake 'DEFS=${DEFS}'
23 }
24
25 do_install() {
26         oe_runmake 'PREFIX=${D}' install
27 }
28
29 FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
30                ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
31                /bin /sbin /lib/*/ /lib/*.so*"