Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / mamona / bash-noemu_3.2.bb
1 require ../bash/bash.inc
2 PR = "r1"
3
4 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
5            file://001-005.patch;patch=1"
6
7 S = "${WORKDIR}/bash-${PV}"
8
9 EXTRA_OECONF += "--enable-static-link --without-bash-malloc"
10
11 #HOST_SYS = "${BUILD_SYS}"
12 #CONFIG_SITE = ""
13
14 do_configure () {
15     export CPP="gcc -E"
16     export CC=gcc
17     export AS=as
18     export LD=ld
19     export CXX=g++ 
20     export AR=ar
21     export OBJCOPY=objcopy 
22     export OBJDUMP=objdump 
23     export RANLIB=ranlib 
24     export NM=nm 
25     export STRIP=strip
26     export CFLAGS="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os"
27     export CXXFLAGS="-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -fpermissive -fvisibility-inlines-hidden"
28     oe_runconf
29 }