Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / madwifi / madwifi-ng_r3314-20080131.bb
1 # Bitbake recipe for the madwifi-ng driver
2
3 # Disable stripping of kernel modules, since this action strips too
4 # much out, and the resulting module won't load.
5 INHIBIT_PACKAGE_STRIP = "1"
6
7 require madwifi-ng_r.inc
8
9 # PR set after the include, to override what's set in the included file.
10 FILE_PR = "r8"
11
12 SRC_URI += "http://sources.dreamboxupdate.com/download/snapshots/openwrt_madwifi_patches_20080829.tar.bz2 \
13         http://sources.dreamboxupdate.com/download/snapshots/ath_hal-20080815.tgz \
14         file://40-fix-warnings.patch;patch=1;pnum=1"
15
16 do_munge() {
17         rm -rf ${S}/hal || /bin/true
18         mv ${WORKDIR}/ath_hal-20080815 ${S}/hal
19         CUR=`pwd`
20         cd ${S}
21         for i in `ls ${WORKDIR}/openwrt_madwifi_patches | grep ".patch" | sort -n | xargs`; do
22                 oenote "Applying openwrt madwifi patch '$i'";
23                 patch -p1 < ${WORKDIR}/openwrt_madwifi_patches/$i;
24         done;
25         cd $CUR
26 }
27
28 addtask munge before do_compile after do_patch