linux-2.6.24: revert addition of qemux86 defconfig, use linux-rp-2.6.24 instead
[vuplus_openembedded] / packages / linux / linux_2.6.24.bb
1 require linux.inc
2
3 # Mark archs/machines that this kernel supports
4 DEFAULT_PREFERENCE = "-1"
5 DEFAULT_PREFERENCE_gesbc-9302 = "1"
6 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
7
8 DEPENDS_append_mpc8313e-rdb = " dtc-native"
9
10 PR = "r6"
11
12 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
13            http://kamikaze.waninkoko.info/patches/2.6.24/kamikaze1/broken-out/squashfs-lzma-2.6.24.patch;patch=1 \
14            file://powerpc-clockres.patch;patch=1 \
15            file://defconfig"
16
17 # Real-time preemption. This is experimental and requires a different defconfig.
18 #SRC_URI += " http://www.kernel.org/pub/linux/kernel/projects/rt/patch-2.6.24-rt1.bz2;patch=1"
19
20 SRC_URI_append_gesbc-9302 = " \
21         file://0001-gesbc-nand.patch;patch=1 \
22         file://0002-gesbc-eth-platform.patch;patch=1 \
23         file://0005-ep93xx-reboot.patch;patch=1 \
24         "
25
26 SRC_URI_append_mpc8313e-rdb = "\
27         file://mpc831x-nand.patch;patch=1 \
28         file://mpc8313e-rdb-leds.patch;patch=1 \
29         file://mpc8313e-rdb-rtc.patch;patch=1"
30
31 CMDLINE_gesbc-9302 = "console=ttyAM0 root=mtd5 rootfstype=jffs2 mtdparts=GESBC-NAND:64m(app),-(data)"
32
33 FILES_kernel-image_gesbc-9302 = ""
34
35 DEVICETREE_mpc8313e-rdb = "arch/${ARCH}/boot/dts/mpc8313erdb.dts"
36 DEVICETREE_FLAGS_mpc8313e-rdb = "-R 8 -S 0x3000"
37
38 do_devicetree_image() {
39         if test -n "${DEVICETREE}" ; then
40             dtc -I dts -O dtb ${DEVICETREE_FLAGS} -o ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.dtb ${DEVICETREE}
41
42             cd ${DEPLOY_DIR_IMAGE}
43             rm -f ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
44             ln -sf ${KERNEL_IMAGE_BASE_NAME}.dtb ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
45         fi
46 }
47
48 addtask devicetree_image after do_deploy before do_package
49