linux_2.6.24: enable serial_cs for simpad
[vuplus_openembedded] / packages / linux / linux_2.6.24.bb
1 require linux.inc
2
3 # Mark archs/machines that this kernel supports
4 DEFAULT_PREFERENCE = "-1"
5 DEFAULT_PREFERENCE_gesbc-9302 = "1"
6 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
7 DEFAULT_PREFERENCE_simpad = "1"
8 DEFAULT_PREFERENCE_atngw100 = "1"
9 DEFAULT_PREFERENCE_at32stk1000 = "1"
10 DEFAULT_PREFERENCE_ts72xx = "1"
11 DEFAULT_PREFERENCE_oxnas = "1"
12 DEFAULT_PREFERENCE_cs-e9302 = "1"
13
14 PR = "r23"
15
16 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
17            http://kamikaze.waninkoko.info/patches/2.6.24/kamikaze1/broken-out/squashfs-lzma-2.6.24.patch;patch=1 \
18            file://time.h.patch;patch=1 \
19            file://defconfig"
20
21 # Moved away temporarely until committed properly (work in progress).
22 #           file://powerpc-clockres.patch;patch=1 \
23 #           file://leds-cpu-activity.patch;patch=1 \
24 #           file://leds-cpu-activity-powerpc.patch;patch=1 \
25
26 SRC_URI_append_simpad = "\
27            file://linux-2.6.24-SIMpad-GPIO-MMC-mod.patch;patch=1 \
28            file://linux-2.6.24-SIMpad-battery-old-way-but-also-with-sysfs.patch;patch=1 \
29            file://linux-2.6.24-SIMpad-cs3-simpad.patch;patch=1 \
30            file://linux-2.6.24-SIMpad-mq200.patch;patch=1 \
31            file://linux-2.6.24-SIMpad-pcmcia.patch;patch=1 \
32            file://linux-2.6.24-SIMpad-serial-gpio_keys-and-cs3-ro.patch.v2;patch=1 \ 
33            file://linux-2.6.24-SIMpad-ucb1x00-switches.patch;patch=1 \
34            file://linux-2.6.24-SIMpad-ucb1x00-ts-supend-and-accuracy.patch;patch=1 \
35            file://linux-2.6.24-SIMpad-hostap_cs-shared-irq.patch;patch=1 \
36            file://linux-2.6.24-SIMpad-orinoco_cs-shared-irq.patch;patch=1 \ 
37            file://linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
38            file://linux-2.6.24-SIMpad-ucb1x00-audio.patch;patch=1 \
39            file://connectplus-remove-ide-HACK.patch;patch=1 \
40            file://collie-kexec.patch;patch=1 \
41            file://export_atags-r2.patch;patch=1 \
42            "       
43
44 SRC_URI_append_gesbc-9302 = " \
45         file://0001-gesbc-nand.patch;patch=1 \
46         file://0002-gesbc-eth-platform.patch;patch=1 \
47         file://0005-ep93xx-reboot.patch;patch=1 \
48         "
49
50 SRC_URI_append_mpc8313e-rdb = "\
51         file://mpc831x-nand.patch;patch=1 \
52         file://mpc8313e-rdb-leds.patch;patch=1 \
53         file://mpc8313e-rdb-rtc.patch;patch=1 \
54         file://mpc8313e-rdb-cardbus.patch;patch=1 \
55         "
56
57 CMDLINE_gesbc-9302 = "console=ttyAM0 root=mtd5 rootfstype=jffs2 mtdparts=GESBC-NAND:64m(app),-(data)"
58
59 SRC_URI_append_cm-x270 = " \
60         file://0001-cm-x270-match-type.patch;patch=1 \
61         file://0002-ramdisk_load.patch;patch=1 \
62         file://0003-mmcsd_large_cards-r0.patch;patch=1 \
63         file://0004-cm-x270-nand-simplify-name.patch;patch=1 \
64         file://0005-add-display-set-default-16bpp.patch;patch=1 \
65         "
66
67 SRC_URI_avr32 = "http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.24.3.atmel.3.tar.bz2 \
68                  file://defconfig"
69 S_avr32 = "${WORKDIR}/linux-2.6.24.3.atmel.3"
70
71 SRC_URI_append_ts72xx = "\
72         file://ep93xx-gpio-interrupt-debounce.diff;patch=1 \
73         file://ep93xx-i2c-bus.diff;patch=1 \
74         file://ep93xx-i2c.diff;patch=1 \
75         file://ep93xx-leds.diff;patch=1 \
76         file://ep93xx-serial-uartbaud.diff;patch=1 \
77         file://ep93xx-serial-clocks.diff;patch=1 \
78         file://ep93xx-timer-accuracy.diff;patch=1 \
79         file://ep93xx-maverick-uniqid.patch;patch=1 \
80         file://ep93xx-eth-phylib-framework.patch;patch=1 \
81         file://ts72xx-nfbit-fix.patch;patch=1 \
82         file://ts72xx-machine-id-fix.patch;patch=1 \
83         file://ts72xx-watchdog.patch;patch=1 \
84         file://ts72xx-use-cpld-reset.patch;patch=1 \
85         file://ts72xx-rs485.patch;patch=1"
86
87 SRC_URI_append_oxnas = " \
88         file://oxnas.diff;patch=1 \
89         file://oxnas-uart.patch;patch=1 \
90         "
91
92 CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
93
94 FILES_kernel-image_gesbc-9302 = ""
95
96 python do_compulab_image() {
97         import os
98         import os.path
99         import struct
100
101         machine = bb.data.getVar('MACHINE', d, 1)
102         if machine == "cm-x270":
103             deploy_dir = bb.data.getVar('DEPLOY_DIR_IMAGE', d, 1)
104             kernel_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.bin')
105             img_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270')
106
107             fo = open(img_file, 'wb')
108
109             image_data = open(kernel_file, 'rb').read()
110
111             # first write size into first 4 bytes
112             size_s = struct.pack('i', len(image_data))
113
114             # truncate size if we are running on a 64-bit host
115             size_s = size_s[:4]
116
117             fo.write(size_s)
118             fo.write(image_data)
119             fo.close()
120
121             os.chdir(deploy_dir)
122             link_file = bb.data.expand('${KERNEL_IMAGE_SYMLINK_NAME}', d) + '.cmx270'
123             img_file = bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270'
124             try:
125                 os.unlink(link_file)
126             except:
127                 pass
128             os.symlink(img_file, link_file)
129 }
130
131
132 addtask compulab_image after do_deploy before do_package
133