KERNEL_IMAGETYPE cleanup
[vuplus_openembedded] / packages / linux / linux-x86_2.6.20.bb
1 DESCRIPTION = "Linux Kernel for x86 compatible machines"
2 SECTION = "kernel"
3 LICENSE = "GPL"
4 PR = "r4"
5
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 " 
7
8 SRC_URI_append_x86 = "file://i486-defconfig"
9 SRC_URI_append_i586 = "file://i586-defconfig"
10 SRC_URI_append_i686 = "file://i686-defconfig"
11
12
13 S = "${WORKDIR}/linux-${PV}"
14
15 inherit kernel
16
17 COMPATIBLE_HOST = "i.86.*-linux"
18
19 do_configure_prepend_x86() {
20         install -m 0644 ${WORKDIR}/i486-defconfig ${S}/.config
21 }
22
23 do_configure_prepend_i586-generic() {
24         install -m 0644 ${WORKDIR}/i586-defconfig ${S}/.config
25 }
26
27 do_configure_prepend_i686() {
28         install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
29 }
30
31
32 do_deploy() {
33         install -d ${DEPLOY_DIR_IMAGE}
34         install -m 0644 arch/i386/boot/${KERNEL_IMAGETYPE}  ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME} 
35 }   
36
37 do_deploy[dirs] = "${S}"
38
39 addtask deploy before do_populate_staging after do_compile