Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / linux / linux-storcenter_2.6.15.7.bb
1 DESCRIPTION = "Linux Kernel for the Iomega storcenter platform"
2 SECTION = "kernel"
3 LICENSE = "GPL"
4 DEPENDS = "u-boot-utils-native"
5 FILE_PR = "r1"
6
7 COMPATIBLE_MACHINE = "storcenter"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
10         file://kernel.patch-${PV};patch=1 \
11         file://defconfig-${PV} "
12
13 S = "${WORKDIR}/linux-${PV}"
14
15 inherit kernel
16
17 export ARCH = "ppc" 
18
19 KERNEL_IMAGETYPE = "uImage"
20 KERNEL_OUTPUT = "arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE}"
21
22 do_configure() {
23         install -m 644 ${WORKDIR}/defconfig-${PV} ${S}/.config
24         make ARCH=${ARCH} oldconfig
25 }