merge of '49118a4c6035353c0f8cf1aa30297dd36e43241f'
[vuplus_openembedded] / packages / linux / linux-rp_2.6.26.bb
1 require linux-rp.inc
2
3 PR = "r1"
4
5 DEFAULT_PREFERENCE = "-1"
6 DEFAULT_PREFERENCE_qemuarm = "-1"
7 DEFAULT_PREFERENCE_qemux86 = "-1"
8 DEFAULT_PREFERENCE_spitz = "1"
9
10 # Handy URLs
11 # git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
12 # ${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2
13 # ${KERNELORG_MIRROR}pub/linux/kernel/v2.6/testing/linux-2.6.20-rc4.tar.bz2
14 # ${KERNELORG_MIRROR}pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;patch=1
15 # ${KERNELORG_MIRROR}pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;patch=1
16 # ${KERNELORG_MIRROR}pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1
17 # ${KERNELORG_MIRROR}pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1
18
19 # Patches submitted upstream are towards top of this list 
20 # Hacks should clearly named and at the bottom
21 SRC_URI = "${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2 \
22            ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1 \
23            ${RPSRC}/hx2750_base-r34.patch;patch=1 \
24            ${RPSRC}/hx2750_bl-r9.patch;patch=1 \
25            ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1 \
26            ${RPSRC}/pxa_keys-r9.patch;patch=1 \
27            ${RPSRC}/tsc2101-r19.patch;patch=1 \
28            ${RPSRC}/hx2750_test1-r8.patch;patch=1 \
29            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
30            ${RPSRC}/pm_changes-r1.patch;patch=1 \
31            ${RPSRC}/locomo_kbd_tweak-r2.patch;patch=1 \
32 #           ${RPSRC}/pxa27x_overlay-r8.patch;patch=1 \
33            ${RPSRC}/w100_extaccel-r2.patch;patch=1 \
34            ${RPSRC}/w100_extmem-r1.patch;patch=1 \
35            ${RPSRC}/poodle_pm-r6.patch;patch=1 \
36            ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1 \
37            ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1 \
38            file://zaurus-i2c-init.patch;patch=1;status=upstream \
39            ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
40            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
41            file://hostap-monitor-mode.patch;patch=1;status=unmergable \
42            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1;status=unmergable \
43            ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
44            ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack \
45            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
46            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
47            file://sharpsl-rc-r1.patch;patch=1 \
48            file://spitz_h_rewrite.patch;patch=1 \
49            file://pxa-serial-hack.patch;patch=1;status=hack \
50            file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
51            file://connectplus-prevent-oops-HACK.patch;patch=1;status=hack \
52            file://htcuni.patch;patch=1 \
53            file://versatile-armv6.patch;patch=1 \
54            file://defconfig-c7x0 \
55            file://defconfig-hx2000 \
56            file://defconfig-akita \
57            file://defconfig-spitz \
58            file://defconfig-qemuarm \
59            file://defconfig-qemux86 \
60            file://defconfig-bootcdx86 \
61            file://defconfig-htcuniversal \
62            file://defconfig-zylonite"
63 # Disabled until the patchset is updated:
64 #           file://defconfig-tosa
65 #           file://defconfig-collie
66 #           file://defconfig-poodle
67
68
69 # FIXMEs before made default       
70 # ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
71
72
73 # Add this to enable pm debug code (useful with a serial lead)
74 #  ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
75
76 # Disabled until I find the reason this gives issues with cdc_subset
77 #            ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
78
79
80 SRC_URI_append_collie = "\
81         ${TKSRC}/mtd-sharp-flash-hack-r4.patch;patch=1 \
82         ${TKSRC}/mcp-sa11x0-r0.patch;patch=1 \
83         ${TKSRC}/locomo-r1.patch;patch=1 \
84         ${TKSRC}/collie-kexec-r1.patch;patch=1 \
85         ${TKSRC}/sharpsl_pm-4.patch;patch=1 \
86         ${TKSRC}/collie_pm-3.patch;patch=1 \
87         ${TKSRC}/ucb1x00_suspend.patch;patch=1 \
88         ${TKSRC}/collie-ts.patch;patch=1 \
89         ${TKSRC}/pcmcia_suspend.patch;patch=1 \
90         ${TKSRC}/locomo_spi-6.patch;patch=1 \
91         ${TKSRC}/config.patch;patch=1 \
92         ${TKSRC}/locomokeyb-2.patch;patch=1 \
93         ${TKSRC}/mmc-spi.patch;patch=1 \
94         ${TKSRC}/linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
95         ${TKSRC}/sa1100_spinlock.patch;patch=1 \
96         ${TKSRC}/sa1100-dma.patch;patch=1 \
97         ${TKSRC}/sa1100_udc_g_ether-2.patch;patch=1 \
98 "
99
100 SRC_URI_append_poodle = "\
101            ${RPSRC}/poodle_serial_vcc-r0.patch;patch=1 \
102            file://poodle_ts.patch;patch=1 \
103            file://pxafb.patch;patch=1 \
104 "
105
106 SRC_URI_append_tosa = "\
107            file://tosa/0001-Allow-runtime-registration-of-regions-of-memory-that.patch;patch=1 \
108            file://tosa/0002-Modify-dma_alloc_coherent-on-ARM-so-that-it-supports.patch;patch=1 \
109            file://tosa/0003-Core-MFD-support.patch;patch=1 \
110            file://tosa/0004-Add-support-for-tc6393xb-MFD-core.patch;patch=1 \
111            file://tosa/0005-Add-support-for-tc6387xb-MFD-core.patch;patch=1 \
112            file://tosa/0006-Add-support-for-t7l66xb-MFD-core.patch;patch=1 \
113            file://tosa/0007-Common-headers-for-TMIO-MFD-subdevices.patch;patch=1 \
114            file://tosa/0008-Nand-driver-for-TMIO-devices.patch;patch=1 \
115            file://tosa/0009-FB-driver-for-TMIO-devices.patch;patch=1 \
116            file://tosa/0010-OHCI-driver-for-TMIO-devices.patch;patch=1 \
117            file://tosa/0011-MMC-driver-for-TMIO-devices.patch;patch=1 \
118            file://tosa/0012-Tosa-keyboard-support.patch;patch=1 \
119            file://tosa/0013-USB-gadget-pxa2xx_udc-supports-inverted-vbus.patch;patch=1 \
120            file://tosa/0014-tosa_udc_use_gpio_vbus.patch.patch;patch=1 \
121            file://tosa/0015-sharpsl-export-params.patch;patch=1 \
122            file://tosa/0016-This-patch-fixes-the-pxa25x-clocks-definitions-to-ad.patch;patch=1 \
123            file://tosa/0017-Convert-pxa2xx-UDC-to-use-debugfs.patch;patch=1 \
124            file://tosa/0018-Fix-the-pxa2xx_udc-to-balance-calls-to-clk_enable-cl.patch;patch=1 \
125            file://tosa/0026-I-don-t-think-we-should-check-for-IRQs-when-determin.patch;patch=1 \
126            file://tosa/0027-Add-LiMn-one-of-the-most-common-for-small-non-recha.patch;patch=1 \
127            file://tosa/0028-Add-suspend-resume-wakeup-support-for-pda_power.patch;patch=1 \
128            file://tosa/0029-Support-using-VOLTAGE_-properties-for-apm-calculati.patch;patch=1 \
129            file://tosa/0030-Core-driver-for-WM97xx-touchscreens.patch;patch=1 \
130            file://tosa/0031-Add-chip-driver-for-WM9705-touchscreen.patch;patch=1 \
131            file://tosa/0032-Add-chip-driver-for-WM9712-touchscreen.patch;patch=1 \
132            file://tosa/0033-Add-chip-driver-for-WM9713-touchscreen.patch;patch=1 \
133            file://tosa/0034-Driver-for-WM97xx-touchscreens-in-streaming-mode-on.patch;patch=1 \
134            file://tosa/0035-Build-system-and-MAINTAINERS-entry-for-WM97xx-touchs.patch;patch=1 \
135            file://tosa/0036-Set-id-to-1-for-wm97xx-subdevices.patch;patch=1 \
136            file://tosa/0037-Don-t-lock-the-codec-list-in-snd_soc_dapm_new_widget.patch;patch=1 \
137            file://tosa/0038-Don-t-lock-the-codec-list-in-snd_soc_dapm_new_widget.patch;patch=1 \
138            file://tosa/0044-fix-tmio_mmc-debug-compilation.patch;patch=1 \
139            file://tosa/0045-Update-tmio_ohci.patch;patch=1 \
140            file://tosa/0046-patch-tc6393xb-cleanup.patch;patch=1 \
141            file://tosa/0047-tc6393xb-use-bitmasks-instead-of-bit-field-structs.patch;patch=1 \
142            file://tosa/0048-tc6393xb-GPIO-support.patch;patch=1 \
143            file://tosa/0049-platform-support-for-TMIO-on-tosa.patch;patch=1 \
144            file://tosa/0050-tosa-update-for-tc6393xb-gpio.patch;patch=1 \
145            file://tosa/0051-fix-sound-soc-pxa-tosa.c-to-new-gpio-api.patch;patch=1 \
146            file://tosa/0052-tosa-platform-backlight-support.patch;patch=1 \
147            file://tosa/0053-sound-soc-codecs-wm9712.c-28.patch;patch=1 \
148            file://tosa/0054-sound-soc-codecs-wm9712.c-2.patch;patch=1 \
149            file://tosa/0055-Add-GPIO_POWERON-to-the-list-of-devices-that-we-supp.patch;patch=1 \
150            file://tosa/0058-Fix-tosakbd-suspend.patch;patch=1 \
151            file://tosa/0059-patch-tosa-wakeup-test.patch;patch=1 \
152            file://tosa/0060-Add-support-for-power_supply-on-tosa.patch;patch=1 \
153            file://tosa/0061-tosa-bat-unify.patch;patch=1 \
154            file://tosa/0062-tosa-bat-fix-charging.patch;patch=1 \
155            file://tosa/0063-patch-tosa-bat-jacket-detect.patch;patch=1 \
156            file://tosa/0064-Export-modes-via-sysfs.patch;patch=1 \
157            file://tosa/0065-wm97xx-core-fixes.patch;patch=1 \
158            file://tosa/0066-tmiofb_probe-should-be-__devinit.patch;patch=1 \
159            file://tosa/0067-modeswitching.patch;patch=1 \
160            file://tosa/0068-Preliminary-tosa-denoiser.patch;patch=1 \
161            file://tosa/0019-pxa-remove-periodic-mode-emulation-support.patch;patch=1 \
162            file://tosa/0020-Provide-dew-device-clock-backports-from-2.6.24-git.patch;patch=1 \
163            file://tosa/0021-Add-an-empty-drivers-gpio-directory-for-gpiolib-infr.patch;patch=1 \
164            file://tosa/0022-Provide-new-implementation-infrastructure-that-platf.patch;patch=1 \
165            file://tosa/0023-This-adds-gpiolib-support-for-the-PXA-architecture.patch;patch=1 \
166            file://tosa/0024-Update-Documentation-gpio.txt-primarily-to-include.patch;patch=1 \
167            file://tosa/0025-Signed-off-by-Dmitry-Baryshkov-dbaryshkov-gmail.co.patch;patch=1 \
168            file://tosa/0039-Add-generic-framework-for-managing-clocks.patch;patch=1 \
169            file://tosa/0040-Clocklib-debugfs-support.patch;patch=1 \
170            file://tosa/0041-From-80a359e60c2aec59ccf4fca0a7fd20495f82b1d2-Mon-Se.patch;patch=1 \
171            file://tosa/0042-Use-correct-clock-for-IrDA-on-pxa.patch;patch=1 \
172            file://tosa/0043-Use-clocklib-for-sa1100-sub-arch.patch;patch=1 \
173            file://tosa/0056-Support-resetting-by-asserting-GPIO-pin.patch;patch=1 \
174            file://tosa/0057-Clean-up-tosa-resetting.patch;patch=1 \
175            "
176
177 SRC_URI_append_htcuniversal ="\
178         file://htcuni-acx.patch;patch=1;status=external \
179         "
180
181 SRC_URI_append_zylonite ="\
182         file://pxa_fb_overlay.patch;patch=1 \
183         file://zylonite-boot.patch;patch=1 \
184         file://zylonite_mtd-r0.patch;patch=1 \
185         file://zylonite_touch-r0.patch;patch=1 \
186         file://zylonite_keypad-r0.patch;patch=1 \
187         "
188
189 S = "${WORKDIR}/linux-2.6.26"