merge of '2641af179102d54034675cfdb4e90ed8d63ee913'
[vuplus_openembedded] / packages / linux / linux-rp_2.6.24.bb
1 require linux-rp.inc
2
3 PR = "r3"
4
5 DEFAULT_PREFERENCE = "-1"
6 DEFAULT_PREFERENCE_collie = "1"
7
8 # Handy URLs
9 # git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
10 # ${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2
11 # ${KERNELORG_MIRROR}pub/linux/kernel/v2.6/testing/linux-2.6.20-rc4.tar.bz2
12 # ${KERNELORG_MIRROR}pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;patch=1
13 # ${KERNELORG_MIRROR}pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;patch=1
14 # ${KERNELORG_MIRROR}pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1
15 # ${KERNELORG_MIRROR}pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1
16
17 # Patches submitted upstream are towards top of this list 
18 # Hacks should clearly named and at the bottom
19 SRC_URI = "${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
20            ${RPSRC}/export_atags-r2.patch;patch=1;status=pending \
21            ${RPSRC}/lzo_crypto-r2.patch;patch=1;status=pending \
22            ${RPSRC}/corgi_rearrange_lcd-r0.patch;patch=1;status=pending \
23            ${RPSRC}/allow_disable_deferrred-r0.patch;patch=1 \
24            ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1 \
25            ${RPSRC}/hx2750_base-r33.patch;patch=1 \
26            ${RPSRC}/hx2750_bl-r9.patch;patch=1 \
27            ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1 \
28            ${RPSRC}/pxa_keys-r8.patch;patch=1 \
29            ${RPSRC}/tsc2101-r18.patch;patch=1 \
30            ${RPSRC}/hx2750_test1-r8.patch;patch=1 \
31            ${RPSRC}/input_power-r10.patch;patch=1 \
32            ${RPSRC}/pxa25x_cpufreq-r2.patch;patch=1 \
33            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
34            ${RPSRC}/pm_changes-r1.patch;patch=1 \
35            ${RPSRC}/usb_add_epalloc-r4.patch;patch=1 \
36            ${RPSRC}/usb_pxa27x_udc-r8.patch;patch=1 \
37            ${RPSRC}/locomo_kbd_tweak-r1.patch;patch=1 \
38            ${RPSRC}/pxa27x_overlay-r8.patch;patch=1 \
39            ${RPSRC}/w100_extaccel-r2.patch;patch=1 \
40            ${RPSRC}/w100_extmem-r1.patch;patch=1 \
41            ${RPSRC}/poodle_pm-r5.patch;patch=1 \
42            ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1 \
43            ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1 \
44            file://squashfs3.3.patch;patch=1;status=external \
45            ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
46            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
47            file://hostap-monitor-mode.patch;patch=1;status=unmergable \
48            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1;status=unmergable \
49            ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
50            ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack \
51            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
52            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
53            file://pxa-serial-hack.patch;patch=1;status=hack \
54            file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
55            file://connectplus-prevent-oops-HACK.patch;patch=1;status=hack \
56            file://htcuni.patch;patch=1 \
57            file://binutils-buildid-arm.patch;patch=1 \
58            file://versatile-armv6.patch;patch=1 \
59            file://defconfig-c7x0 \
60            file://defconfig-hx2000 \
61            file://defconfig-collie \
62            file://defconfig-poodle \
63            file://defconfig-akita \
64            file://defconfig-spitz \
65            file://defconfig-qemuarm \
66            file://defconfig-qemux86 \
67            file://defconfig-bootcdx86 \
68            file://defconfig-htcuniversal \
69            file://defconfig-zylonite"
70 # Tosa disabled until the patchset is updated
71 #           file://defconfig-tosa
72
73 # FIXMEs before made default       
74 # ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
75
76
77 # Add this to enable pm debug code (useful with a serial lead)
78 #  ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
79
80 # Disabled until I find the reason this gives issues with cdc_subset
81 #            ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
82
83 # Is anything out of this still needed? Parts were commited to mainline by rmk (drivers/mfd/)
84 # (Pavel Machek's git tree has updated versions of this?)
85 #  ${JLSRC}/zaurus-lcd-2.6.11.diff.gz;patch=1
86
87 # These patches are extracted from Pavel Machek's git tree
88 # (diff against vanilla kernel)
89 SRC_URI_append_collie = "\
90         ${TKSRC}/mtd-sharp-flash-hack-r3.patch;patch=1 \
91         ${TKSRC}/mcp-sa11x0-r0.patch;patch=1 \
92         ${TKSRC}/locomo-r0.patch;patch=1 \
93 #       ${TKSRC}/locomo_spi-4.patch;patch=1 \
94         ${TKSRC}/collie-kexec.patch;patch=1 \
95         ${TKSRC}/sharpsl_pm-3.patch;patch=1 \
96         ${TKSRC}/collie_pm-2.patch;patch=1 \
97         ${TKSRC}/locomokeyb_suspendkey-2.patch;patch=1 \
98         ${TKSRC}/ucb1x00_suspend.patch;patch=1 \
99         ${TKSRC}/collie-ts.patch;patch=1 \
100         ${TKSRC}/pcmcia_suspend.patch;patch=1 \
101 "
102
103 SRC_URI_append_poodle = "\
104            ${RPSRC}/poodle_serial_vcc-r0.patch;patch=1 \
105            file://poodle_ts.patch;patch=1 \
106            file://pxafb.patch;patch=1 \
107 "
108
109 SRC_URI_append_tosa = "\
110            ${CHSRC}/tmio-core-r4.patch;patch=1 \
111            file://tmio-tc6393-r8.patch;patch=1 \
112            file://tmio-nand-r8.patch;patch=1 \
113            ${CHSRC}/tmio-fb-r6.patch;patch=1 \
114            file://tmio-fb-r6-fix-r0.patch;patch=1 \
115            file://tosa-keyboard-r19.patch;patch=1 \
116            ${DOSRC}/tosa-pxaac97-r6.patch;patch=1 \
117            file://tosa-pxaac97-r6-fix-r0.patch;patch=1 \
118            ${DOSRC}/tosa-tmio-r6.patch;patch=1 \
119            file://tosa-power-r18.patch;patch=1 \
120            file://tosa-power-r18-fix-r0.patch;patch=1 \
121            file://tosa-tmio-lcd-r10.patch;patch=1 \
122            file://tosa-tmio-lcd-r10-fix-r0.patch;patch=1 \
123            file://tosa-bluetooth-r8.patch;patch=1 \
124            file://wm97xx-lg13-r0.patch;patch=1 \
125            file://wm97xx-lg13-r0-fix-r0.patch;patch=1 \
126            file://wm9712-suspend-cold-res-r2.patch;patch=1 \
127            file://sharpsl-pm-postresume-r1.patch;patch=1 \
128            file://wm9712-reset-loop-r2.patch;patch=1 \
129            file://tosa-lcdnoise-r1.patch;patch=1 \
130            file://tosa-lcdnoise-r1-fix-r0.patch;patch=1 \
131            file://arm-dma-coherent.patch;patch=1 \
132            file://usb-ohci-hooks-r3.patch;patch=1 \
133            file://tmio-ohci-r9.patch;patch=1 \
134            file://pxa2xx_udc_support_inverse_vbus.patch;patch=1 \
135            file://tosa_udc_use_gpio_vbus.patch;patch=1 \
136            "
137 #          ${DOSRC}/tosa-asoc-r1.patch;patch=1 "
138
139 SRC_URI_append_akita = "\
140            file://mtd-module.patch;patch=1;status=external \
141            file://wm8750-treble.patch;patch=1;status=external \
142            file://sharpsl-rc-r1.patch;patch=1 \
143            "
144
145 SRC_URI_append_spitz = "\
146            file://mtd-module.patch;patch=1;status=external \
147            file://wm8750-treble.patch;patch=1;status=external \
148            file://sharpsl-rc-r1.patch;patch=1 \
149            "
150
151 SRC_URI_append_htcuniversal ="\
152         file://htcuni-acx.patch;patch=1;status=external \
153         "
154
155 SRC_URI_append_zylonite ="\
156         file://pxa_fb_overlay.patch;patch=1 \
157         file://zylonite-boot.patch;patch=1 \
158         "
159
160 S = "${WORKDIR}/linux-2.6.24"