merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / linux / linux-rp_2.6.17.bb
1 require linux-rp.inc
2
3 PR = "r31"
4
5 # Handy URLs
6 # git://rsync.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git \
7 # http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.14.tar.gz \
8 # http://www.kernel.org/pub/linux/kernel/v2.6/testing/patch-2.6.15-rc1.bz2;patch=1 \
9 # http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-2.6.15-rc2-git1.bz2;patch=1 \
10 # http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1 \
11 # http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1 \    
12
13 # Patches submitted upstream are towards top of this list 
14 # Hacks should clearly named and at the bottom
15 SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.17.tar.bz2 \
16            ${RPSRC}/poodle_partsize-r0.patch;patch=1;status=merged \
17            ${RPSRC}/jffs2_longfilename-r1.patch;patch=1;status=merged \
18            ${RPSRC}/locomo_led_default_trigger-r0.patch;patch=1;status=merged \
19            ${RPSRC}/zaurus_reboot-r3.patch;patch=1;status=merged \
20            ${RPSRC}/poodle_mmcsd_fix-r0.patch;patch=1;status=merged \
21            ${RPSRC}/poodle_ssp-r1.patch;patch=1;status=merged \
22            ${RPSRC}/sharpsl_pm-do-r2.patch;patch=1;status=merged \
23            ${RPSRC}/zlib_inflate-r3.patch;patch=1;status=merged \
24            ${RPSRC}/logo_rotate_fix-r1.patch;patch=1;status=merged \
25            ${RPSRC}/collie_frontlight-r6.patch;patch=1;status=merged \
26            ${RPSRC}/input_modalias_fix-r0.patch;patch=1;status=merged \
27            ${RPSRC}/spectrumcs_fix-r0.patch;patch=1 \
28            file://00-hostap.patch;patch=1;status=merged \
29            file://10-pcnet.patch;patch=1;status=merged \
30            file://asoc-v0.12.4_2.6.17.patch;patch=1 \
31            ${RPSRC}/hx2750_base-r27.patch;patch=1 \
32            ${RPSRC}/hx2750_bl-r7.patch;patch=1 \
33            ${RPSRC}/hx2750_pcmcia-r2.patch;patch=1 \
34            ${RPSRC}/pxa_keys-r5.patch;patch=1 \
35            ${RPSRC}/tsc2101-r12.patch;patch=1 \
36            ${RPSRC}/hx2750_test1-r4.patch;patch=1 \
37            ${RPSRC}/pxa_timerfix-r0.patch;patch=1 \
38            ${RPSRC}/input_power-r5.patch;patch=1 \
39            ${RPSRC}/pxa25x_cpufreq-r0.patch;patch=1 \
40            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
41            ${RPSRC}/pm_changes-r1.patch;patch=1 \
42            ${RPSRC}/usb_pxa27x_udc-r0.patch;patch=1 \
43            ${RPSRC}/usb_add_epalloc-r1.patch;patch=1 \
44            ${DOSRC}/kexec-arm-r3.patch;patch=1 \
45            ${RPSRC}/locomo_kbd_tweak-r1.patch;patch=1 \
46            ${RPSRC}/poodle_pm-r3.patch;patch=1 \
47            ${RPSRC}/pxafb_changeres-r0.patch;patch=1 \
48            ${RPSRC}/poodle_audio-r7.patch;patch=1 \
49            ${RPSRC}/pxa27x_overlay-r2.patch;patch=1 \
50            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1 \
51            file://hrw-pcmcia-ids-r5.patch;patch=1 \
52            ${RPSRC}/logo_oh-r0.patch.bz2;patch=1;status=unmergable \
53            ${RPSRC}/logo_oz-r2.patch.bz2;patch=1;status=unmergable \
54            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
55            file://add-oz-release-string.patch;patch=1;status=unmergable \
56            ${RPSRC}/mmcsd_large_cards-r0.patch;patch=1;status=hack \
57            ${RPSRC}/mmcsd_no_scr_check-r0.patch;patch=1;status=hack \
58            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
59            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
60            file://pxa-serial-hack.patch;patch=1;status=hack \
61            file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
62            file://orinoco-remove-all-which-are-in-hostap-HACK.patch;patch=1;status=unmergable-hack \
63            file://squashfs3.0-2.6.15.patch;patch=1;status=external \
64            file://vesafb-tng-1.0-rc2-git-20060629.patch;patch=1;status=external \
65            file://defconfig-c7x0 \
66            file://defconfig-hx2000 \
67            file://defconfig-collie \
68            file://defconfig-poodle \
69            file://defconfig-akita \
70            file://defconfig-spitz \
71            file://defconfig-qemuarm \
72            file://defconfig-qemux86 \
73            file://defconfig-tosa "
74
75 # Add this to enable pm debug code (useful with a serial lead)
76 #  ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
77
78 # Disabled until I find the reason this gives issues with cdc_subset
79 #            ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
80
81 #           http://tglx.de/projects/armirq/2.6.17-rc3/patch-2.6.17-rc3-armirq4.patch;patch=1 \
82 #           ${RPSRC}/../pxa27x_overlay-r0.patch;patch=1 \
83
84 # Is anything out of this still needed? Parts were commited to mainline by rmk (drivers/mfd/)
85 # (Pavel Machek's git tree has updated versions of this?)
86 #  ${JLSRC}/zaurus-lcd-2.6.11.diff.gz;patch=1 
87
88 # These patches are extracted from Pavel Machek's git tree
89 # (diff against vanilla kernel)
90 SRC_URI_append_collie = "\
91            ${DOSRC}/collie/mtd-sharp-flash-hack-r0.patch;patch=1 \
92            ${DOSRC}/collie/collie-r0.patch;patch=1 \
93            ${DOSRC}/collie/locomolcd-backlight-r0.patch;patch=1 \
94            ${DOSRC}/collie/ucb1x00-touch-audio-r0.patch;patch=1 \
95            ${DOSRC}/collie/collie-mcp-r0.patch;patch=1 \
96            ${DOSRC}/collie/sa1100-udc-r0.patch;patch=1 \
97 #          ${DOSRC}/collie/collie-pm-r1.patch;patch=1 \
98            "
99
100 SRC_URI_append_tosa = "\
101            ${CHSRC}/usb-ohci-hooks-r1.patch;patch=1 \
102            ${CHSRC}/tmio-core-r4.patch;patch=1 \
103            ${DOSRC}/temp/tmio-tc6393-r6.patch;patch=1 \
104            ${CHSRC}/tmio-nand-r5.patch;patch=1 \
105            ${DOSRC}/temp/tmio-ohci-r4.patch;patch=1 \
106            ${CHSRC}/tmio-fb-r6.patch;patch=1 \
107            ${DOSRC}/tosa-keyboard-r17.patch;patch=1 \
108            ${DOSRC}/tosa-pxaac97-r6.patch;patch=1 \
109            ${DOSRC}/tosa-tmio-r6.patch;patch=1 \
110            ${DOSRC}/tosa-power-r17.patch;patch=1 \
111            ${DOSRC}/tosa-tmio-lcd-r8.patch;patch=1 \
112            ${DOSRC}/tosa-bluetooth-r8.patch;patch=1 \
113            ${DOSRC}/wm97xx-lg7-r0.patch;patch=1 \
114            ${DOSRC}/wm9712-suspend-cold-res-r1.patch;patch=1 \
115            ${DOSRC}/sharpsl-pm-postresume-r0.patch;patch=1 \
116            ${DOSRC}/wm97xx-dig-restore-r0.patch;patch=1 \
117            ${DOSRC}/wm97xx-miscdevs-resume-r0.patch;patch=1 \
118            ${DOSRC}/wm9712-reset-loop-r1.patch;patch=1 \
119            file://tosa-lcdnoise-r0.patch;patch=1 \
120            file://wm97xx-lcdnoise-r0.patch;patch=1 "
121 #          ${DOSRC}/tosa-asoc-r1.patch;patch=1 "
122
123 S = "${WORKDIR}/linux-2.6.17"
124
125 # to get module dependencies working
126 KERNEL_RELEASE = "2.6.17"