conf/distro/jlime-donkey.conf : Added parted & Dialog to distro_rdepends
[vuplus_openembedded] / packages / linux / linux-openzaurus_2.6.18.bb
1 require linux-openzaurus.inc
2
3 PR = "r5"
4
5 # Handy URLs
6 # git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
7 # http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.18.tar.gz
8 # http://www.kernel.org/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;patch=1
9 # http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;patch=1
10 # http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1
11 # http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1
12
13 # Patches submitted upstream are towards top of this list 
14 # Hacks should clearly named and at the bottom
15 SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
16            ${RPSRC}/alsa/asoc-v0.12.patch;patch=1 \
17            ${RPSRC}/asoc_makefile-r1.patch;patch=1 \
18            ${RPSRC}/poodle_audio-r6.patch;patch=1 \
19            ${RPSRC}/hx2750_base-r27.patch;patch=1 \
20            ${RPSRC}/hx2750_bl-r7.patch;patch=1 \
21            ${RPSRC}/hx2750_pcmcia-r2.patch;patch=1 \
22            ${RPSRC}/pxa_keys-r5.patch;patch=1 \
23            ${RPSRC}/tsc2101-r12.patch;patch=1 \
24            ${RPSRC}/hx2750_test1-r4.patch;patch=1 \
25            ${RPSRC}/pxa_timerfix-r0.patch;patch=1 \
26            ${RPSRC}/input_power-r5.patch;patch=1 \
27            ${RPSRC}/pxa25x_cpufreq-r1.patch;patch=1 \
28            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
29            ${RPSRC}/pm_changes-r1.patch;patch=1 \
30            ${RPSRC}/usb_pxa27x_udc-r0.patch;patch=1 \
31            ${RPSRC}/usb_add_epalloc-r3.patch;patch=1 \
32            ${DOSRC}/kexec-arm-r3.patch;patch=1 \
33            ${RPSRC}/locomo_kbd_tweak-r1.patch;patch=1 \
34            ${RPSRC}/poodle_pm-r3.patch;patch=1 \
35            ${RPSRC}/pxafb_changeres-r2.patch;patch=1 \
36            ${RPSRC}/pxa27x_overlay-r2.patch;patch=1 \
37            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1 \
38            file://hrw-pcmcia-ids-r5.patch;patch=1 \
39            ${RPSRC}/logo_oh-r0.patch.bz2;patch=1;status=unmergable \
40            ${RPSRC}/logo_oz-r2.patch.bz2;patch=1;status=unmergable \
41            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
42            file://add-oz-release-string.patch;patch=1;status=unmergable \
43            ${RPSRC}/mmcsd_large_cards-r0.patch;patch=1;status=hack \
44            ${RPSRC}/mmcsd_no_scr_check-r0.patch;patch=1;status=hack \
45            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
46            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
47            file://pxa-serial-hack.patch;patch=1;status=hack \
48            file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
49            file://orinoco-remove-all-which-are-in-hostap-HACK.patch;patch=1;status=unmergable-hack \
50            file://squashfs3.0-2.6.15.patch;patch=1;status=external \
51            file://defconfig-c7x0 \
52            file://defconfig-hx2000 \
53            file://defconfig-collie \
54            file://defconfig-poodle \
55            file://defconfig-akita \
56            file://defconfig-spitz \
57            file://defconfig-qemuarm \
58            file://defconfig-qemux86 \
59            file://defconfig-tosa "
60
61 # Add this to enable pm debug code (useful with a serial lead)
62 #  ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
63
64 # Disabled until I find the reason this gives issues with cdc_subset
65 #            ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
66
67 # Is anything out of this still needed? Parts were commited to mainline by rmk (drivers/mfd/)
68 # (Pavel Machek's git tree has updated versions of this?)
69 #  ${JLSRC}/zaurus-lcd-2.6.11.diff.gz;patch=1 
70
71 # These patches are extracted from Pavel Machek's git tree
72 # (diff against vanilla kernel)
73 SRC_URI_append_collie = "\
74            ${DOSRC}/collie/mtd-sharp-flash-hack-r0.patch;patch=1 \
75            ${DOSRC}/collie/collie-r0.patch;patch=1 \
76            ${DOSRC}/collie/locomolcd-backlight-r0.patch;patch=1 \
77            ${DOSRC}/collie/ucb1x00-touch-audio-r0.patch;patch=1 \
78            file://collie-mcp-r1.patch;patch=1 \
79            ${DOSRC}/collie/sa1100-udc-r0.patch;patch=1 \
80 #          ${DOSRC}/collie/collie-pm-r1.patch;patch=1 \
81 "
82
83 SRC_URI_append_tosa = "\
84            ${CHSRC}/usb-ohci-hooks-r1.patch;patch=1 \
85            ${CHSRC}/tmio-core-r4.patch;patch=1 \
86            file://tmio-tc6393-r7.patch;patch=1 \
87            file://tmio-nand-r6.patch;patch=1 \
88            file://tmio-ohci-r5.patch;patch=1 \
89            ${CHSRC}/tmio-fb-r6.patch;patch=1 \
90            ${DOSRC}/tosa-keyboard-r17.patch;patch=1 \
91            ${DOSRC}/tosa-pxaac97-r6.patch;patch=1 \
92            ${DOSRC}/tosa-tmio-r6.patch;patch=1 \
93            ${DOSRC}/tosa-power-r17.patch;patch=1 \
94            file://tosa-tmio-lcd-r9.patch;patch=1 \
95            ${DOSRC}/tosa-bluetooth-r8.patch;patch=1 \
96            ${DOSRC}/wm97xx-lg7-r0.patch;patch=1 \
97            ${DOSRC}/wm9712-suspend-cold-res-r1.patch;patch=1 \
98            ${DOSRC}/sharpsl-pm-postresume-r0.patch;patch=1 \
99            ${DOSRC}/wm97xx-dig-restore-r0.patch;patch=1 \
100            ${DOSRC}/wm97xx-miscdevs-resume-r0.patch;patch=1 \
101            ${DOSRC}/wm9712-reset-loop-r1.patch;patch=1 \
102            file://tosa-lcdnoise-r1.patch;patch=1 \
103            file://wm97xx-lcdnoise-r0.patch;patch=1 "
104 #          ${DOSRC}/tosa-asoc-r1.patch;patch=1 "
105
106 S = "${WORKDIR}/linux-2.6.18"
107
108 # to get module dependencies working
109 KERNEL_RELEASE = "2.6.18"